SynSoft .NET Libraries

SynSoft is a non-commercial imprint of Synesis Software Pty Ltd, an Australian Software Engineering Consultancy firm. The purpose of SynSoft is to be an outlet for D, Java, .NET, Perl and Python software that has been built by Synesis Software.

All SynSoft software is provided (in source code and/or binary format) to the development community according to the Synesis Software Standard Public License (SSSPL). (Basically, the license requires that users do not claim ownership nor charge for this software, and allows inclusion in any commercial or non-commercial software developments.) No warranties of any kind are provided.

The SynSoft .NET components come in binary assembly form, accompanied by XML documentation files (facilitating Visual Studio.NET Intellisense) and help files (HTML and HTML Help).

Namespaces and Assemblies

The current release of the SynSoft .NET libraries contain the following namespaces and classes.

Namespace | Assembly | Description
SynSoft.Collections | SynSoft.NET.Coll.dll | This namespace contains algorithms and classes for representing, managing and manipulating collections of objects
SynSoft.Conversion | SynSoft.NET.Conv.dll | This namespace contains algorithms and classes for controlling and facilitating conversions between types within the CLR
SynSoft.Performance | SynSoft.NET.Perf.dll | This namespace contains classes used for measuring performance intervals
SynSoft.Security | SynSoft.NET.Perf.dll | This namespace contains classes for querying and manipulating Win32 Security information. Note: Although the first version of this component is available, the online help is not yet available. This will be in place for the next release of the libraries.
SynSoft.Text | SynSoft.NET.Text.dll | This namespace contains algorithms and classes for representing, managing and manipulating text

Copyright © Synesis Software Pty Ltd, 2002-2003


SynSoft.Collections

SynSoft .NET Libraries (release 3rd July 2003)

SynSoft.Collections Namespace

Classes

Class | Description
Sorter | The sorter class provides algorithms for implementing sorting behaviour


Sorter Class

The sorter class provides algorithms for implementing sorting behaviour

For a list of all members of this type, see Sorter Members.

System.Object
Sorter

[Visual Basic]
Public Class Sorter
[C#]
public class Sorter

Requirements

Namespace: SynSoft.Collections Namespace

Assembly: SynSoft.NET.Coll.dll

See Also

Sorter Members | SynSoft.Collections Namespace

Copyright © Synesis Software Pty Ltd, 2002-2003

Generated from assembly SynSoft.NET.Coll [1.0.1279.28854]


Sorter Members

Public Static (Shared) Methods

RemoveDuplicates Overloaded. Removes the duplicates from the unordered sequence

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Sorter Class | SynSoft.Collections Namespace

Copyright © Synesis Software Pty Ltd, 2002-2003

Generated from assembly SynSoft.NET.Coll [1.0.1279.28854]


Sorter Methods

The methods of the Sorter class are listed below. For a complete list of Sorter class members, see the Sorter Members topic.

Public Static (Shared) Methods

RemoveDuplicates Overloaded. Removes the duplicates from the unordered sequence

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Sorter Class | SynSoft.Collections Namespace

Copyright © Synesis Software Pty Ltd, 2002-2003

Generated from assembly SynSoft.NET.Coll [1.0.1279.28854]


RemoveDuplicates Method

SynSoft .NET Libraries (release 3rd July 2003)

Sorter.RemoveDuplicates Method

Removes the duplicates from the unordered sequence

Overload List

Removes the duplicates from the unordered sequence

public static string[] RemoveDuplicates(string[],bool);

Removes the duplicates from the unordered sequence, eliding any empty strings from the result

public static string[] RemoveDuplicates(string[]);

Removes the duplicates from the unordered sequence

public static object[] RemoveDuplicates(object[]);

See Also

Sorter Class | Sorter Members | SynSoft.Collections Namespace

Copyright © Synesis Software Pty Ltd, 2002-2003

Generated from assembly SynSoft.NET.Coll [1.0.1279.28854]


Sorter.RemoveDuplicates Method (Object[])

Removes the duplicates from the unordered sequence

[Visual Basic]
Overloads Public Shared Function RemoveDuplicates( _
   ByVal objects As Object() _
) As Object()
[C#]
public static object[] RemoveDuplicates(
object[] objects
);

See Also

Sorter Class | Sorter Members | SynSoft.Collections Namespace | Sorter.RemoveDuplicates Overload List

Copyright © Synesis Software Pty Ltd, 2002-2003

Generated from assembly SynSoft.NET.Coll [1.0.1279.28854]


Sorter.RemoveDuplicates Method (String[])

Removes the duplicates from the unordered sequence, eliding any empty strings from the result

[Visual Basic]
Overloads Public Shared Function RemoveDuplicates( _
   ByVal strings As String() _
) As String()
[C#]
public static string[] RemoveDuplicates(
string[] strings
);

See Also

Sorter Class | Sorter Members | SynSoft.Collections Namespace | Sorter.RemoveDuplicates Overload List

Copyright © Synesis Software Pty Ltd, 2002-2003

Generated from assembly SynSoft.NET.Coll [1.0.1279.28854]


Sorter.RemoveDuplicates Method (String[], Boolean)

Removes the duplicates from the unordered sequence

[Visual Basic]
Overloads Public Shared Function RemoveDuplicates( _
   ByVal strings As String(), _
   ByVal elideEmptyStrings As Boolean _
) As String()
[C#]
public static string[] RemoveDuplicates(
string[] strings,
bool elideEmptyStrings
);

Parameters

strings
The sequence of strings to process
elideEmptyStrings
Determines whether to leave empty strings, if any, in the sequence

Return Value

See Also

Sorter Class | Sorter Members | SynSoft.Collections Namespace | Sorter.RemoveDuplicates Overload List

Copyright © Synesis Software Pty Ltd, 2002-2003

Generated from assembly SynSoft.NET.Coll [1.0.1279.28854]


SynSoft.Conversion

SynSoft .NET Libraries (release 3rd July 2003)

SynSoft.Conversion Namespace

Classes

Class | Description
TypeCaster | This class provides methods for casting between types.
TypeCastException | This class is thrown to indicate a type-cast failure


TypeCaster Class

This class provides methods for casting between types.

For a list of all members of this type, see TypeCaster Members.

System.Object
TypeCaster

[Visual Basic]
NotInheritable Public Class TypeCaster
[C#]
public sealed class TypeCaster

Requirements

Namespace: SynSoft.Conversion Namespace

Assembly: SynSoft.NET.Conv.dll

See Also

TypeCaster Members | SynSoft.Conversion Namespace

Copyright © Synesis Software Pty Ltd, 2002-2003

Generated from assembly SynSoft.NET.Conv [1.0.1279.28854]


TypeCaster Members

Public Static (Shared) Methods

bool_cast | Overloaded. Casts the given value to a Boolean
byte_cast | Overloaded. Casts to a byte
char_cast | Overloaded. Casts the given value to a Boolean
double_cast | Overloaded. Casts to a double
float_cast | Overloaded. Casts to a float
int_cast | Overloaded. Casts to a int
long_cast | Overloaded. Casts to a long
sbyte_cast | Overloaded. Casts to a sbyte
short_cast | Overloaded. Casts to a short
uint_cast | Overloaded. Casts to a uint
ulong_cast | Overloaded. Casts to a ulong
ushort_cast | Overloaded. Casts to a ushort

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

TypeCaster Class | SynSoft.Conversion Namespace

Copyright © Synesis Software Pty Ltd, 2002-2003

Generated from assembly SynSoft.NET.Conv [1.0.1279.28854]


TypeCaster Methods

The methods of the TypeCaster class are listed below. For a complete list of TypeCaster class members, see the TypeCaster Members topic.

Public Static (Shared) Methods

bool_cast | Overloaded. Casts the given value to a Boolean
byte_cast | Overloaded. Casts to a byte
char_cast | Overloaded. Casts the given value to a Boolean
double_cast | Overloaded. Casts to a double
float_cast | Overloaded. Casts to a float
int_cast | Overloaded. Casts to a int
long_cast | Overloaded. Casts to a long
sbyte_cast | Overloaded. Casts to a sbyte
short_cast | Overloaded. Casts to a short
uint_cast | Overloaded. Casts to a uint
ulong_cast | Overloaded. Casts to a ulong
ushort_cast | Overloaded. Casts to a ushort

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

TypeCaster Class | SynSoft.Conversion Namespace

Copyright © Synesis Software Pty Ltd, 2002-2003

Generated from assembly SynSoft.NET.Conv [1.0.1279.28854]


bool_cast Method

SynSoft .NET Libraries (release 3rd July 2003)

TypeCaster.bool_cast Method

Casts the given value to a Boolean

Overload List

Casts the given value to a Boolean

public static bool bool_cast(bool);

Casts the given value to a Boolean

public static bool bool_cast(object);

See Also

TypeCaster Class | TypeCaster Members | SynSoft.Conversion Namespace

Copyright © Synesis Software Pty Ltd, 2002-2003

Generated from assembly SynSoft.NET.Conv [1.0.1279.28854]


TypeCaster.bool_cast Method (Boolean)

Casts the given value to a Boolean

[Visual Basic]
Overloads Public Shared Function bool_cast( _
   ByVal v As Boolean _
) As Boolean
[C#]
public static bool bool_cast(
bool v
);

Parameters

v
The value to convert

Return Value

See Also

TypeCaster Class | TypeCaster Members | SynSoft.Conversion Namespace | TypeCaster.bool_cast Overload List

Copyright © Synesis Software Pty Ltd, 2002-2003

Generated from assembly SynSoft.NET.Conv [1.0.1279.28854]


TypeCaster.bool_cast Method (Object)

Casts the given value to a Boolean

[Visual Basic]
Overloads Public Shared Function bool_cast( _
   ByVal v As Object _
) As Boolean
[C#]
public static bool bool_cast(
object v
);

Parameters

v
The value to convert

Return Value

See Also

TypeCaster Class | TypeCaster Members | SynSoft.Conversion Namespace | TypeCaster.bool_cast Overload List

Copyright © Synesis Software Pty Ltd, 2002-2003

Generated from assembly SynSoft.NET.Conv [1.0.1279.28854]


byte_cast Method

SynSoft .NET Libraries (release 3rd July 2003)

TypeCaster.byte_cast Method

Casts to a byte

Overload List

Casts to a byte

public static byte byte_cast(byte);

Casts to a byte

public static byte byte_cast(object,bool);

Casts to a byte, disallowing conversion from signed types

public static byte byte_cast(object);

See Also

TypeCaster Class | TypeCaster Members | SynSoft.Conversion Namespace

Copyright © Synesis Software Pty Ltd, 2002-2003

Generated from assembly SynSoft.NET.Conv [1.0.1279.28854]


TypeCaster.byte_cast Method (Byte)

Casts to a byte

[Visual Basic]
Overloads Public Shared Function byte_cast( _
   ByVal v As Byte _
) As Byte
[C#]
public static byte byte_cast(
byte v
);

Parameters

v
The value to cast from

Return Value

See Also

TypeCaster Class | TypeCaster Members | SynSoft.Conversion Namespace | TypeCaster.byte_cast Overload List

Copyright © Synesis Software Pty Ltd, 2002-2003

Generated from assembly SynSoft.NET.Conv [1.0.1279.28854]


TypeCaster.byte_cast Method (Object)

Casts to a byte, disallowing conversion from signed types

[Visual Basic]
Overloads Public Shared Function byte_cast( _
   ByVal v As Object _
) As Byte
[C#]
public static byte byte_cast(
object v
);

Parameters

v
The value to cast from

Return Value

See Also

TypeCaster Class | TypeCaster Members | SynSoft.Conversion Namespace | TypeCaster.byte_cast Overload List

Copyright © Synesis Software Pty Ltd, 2002-2003

Generated from assembly SynSoft.NET.Conv [1.0.1279.28854]


TypeCaster.byte_cast Method (Object, Boolean)

Casts to a byte

[Visual Basic]
Overloads Public Shared Function byte_cast( _
   ByVal v As Object, _
   ByVal bAcceptSigned As Boolean _
) As Byte
[C#]
public static byte byte_cast(
object v,
bool bAcceptSigned
);

Parameters

v
The value to cast from
bAcceptSigned
Determines whether conversion from signed types will be attempted

Return Value

See Also

TypeCaster Class | TypeCaster Members | SynSoft.Conversion Namespace | TypeCaster.byte_cast Overload List

Copyright © Synesis Software Pty Ltd, 2002-2003

Generated from assembly SynSoft.NET.Conv [1.0.1279.28854]


char_cast Method

SynSoft .NET Libraries (release 3rd July 2003)

TypeCaster.char_cast Method

Casts the given value to a Boolean

Overload List

Casts the given value to a Boolean

public static char char_cast(char);

Casts the given value to a Boolean

public static char char_cast(object);

See Also

TypeCaster Class | TypeCaster Members | SynSoft.Conversion Namespace

Copyright © Synesis Software Pty Ltd, 2002-2003

Generated from assembly SynSoft.NET.Conv [1.0.1279.28854]


TypeCaster.char_cast Method (Char)

Casts the given value to a Boolean

[Visual Basic]
Overloads Public Shared Function char_cast( _
   ByVal v As Char _
) As Char
[C#]
public static char char_cast(
char v
);

Parameters

v
The value to convert

Return Value

See Also

TypeCaster Class | TypeCaster Members | SynSoft.Conversion Namespace | TypeCaster.char_cast Overload List

Copyright © Synesis Software Pty Ltd, 2002-2003

Generated from assembly SynSoft.NET.Conv [1.0.1279.28854]


TypeCaster.char_cast Method (Object)

Casts the given value to a Boolean

[Visual Basic]
Overloads Public Shared Function char_cast( _
   ByVal v As Object _
) As Char
[C#]
public static char char_cast(
object v
);

Parameters

v
The value to convert

Return Value

See Also

TypeCaster Class | TypeCaster Members | SynSoft.Conversion Namespace | TypeCaster.char_cast Overload List

Copyright © Synesis Software Pty Ltd, 2002-2003

Generated from assembly SynSoft.NET.Conv [1.0.1279.28854]


double_cast Method

SynSoft .NET Libraries (release 3rd July 2003)

TypeCaster.double_cast Method

Casts to a double

Overload List

Casts to a double

public static double double_cast(double);

Casts to a double

public static double double_cast(float);

Casts to a double

public static double double_cast(object);

See Also

TypeCaster Class | TypeCaster Members | SynSoft.Conversion Namespace

Copyright © Synesis Software Pty Ltd, 2002-2003

Generated from assembly SynSoft.NET.Conv [1.0.1279.28854]


TypeCaster.double_cast Method (Double)

Casts to a double

[Visual Basic]
Overloads Public Shared Function double_cast( _
   ByVal v As Double _
) As Double
[C#]
public static double double_cast(
double v
);

Parameters

v
The value to cast from

Return Value

See Also

TypeCaster Class | TypeCaster Members | SynSoft.Conversion Namespace | TypeCaster.double_cast Overload List

Copyright © Synesis Software Pty Ltd, 2002-2003

Generated from assembly SynSoft.NET.Conv [1.0.1279.28854]


TypeCaster.double_cast Method (Object)

Casts to a double

[Visual Basic]
Overloads Public Shared Function double_cast( _
   ByVal v As Object _
) As Double
[C#]
public static double double_cast(
object v
);

Parameters

v
The value to cast from

Return Value

See Also

TypeCaster Class | TypeCaster Members | SynSoft.Conversion Namespace | TypeCaster.double_cast Overload List

Copyright © Synesis Software Pty Ltd, 2002-2003

Generated from assembly SynSoft.NET.Conv [1.0.1279.28854]


TypeCaster.double_cast Method (Single)

Casts to a double

[Visual Basic]
Overloads Public Shared Function double_cast( _
   ByVal v As Single _
) As Double
[C#]
public static double double_cast(
float v
);

Parameters

v
The value to cast from

Return Value

See Also

TypeCaster Class | TypeCaster Members | SynSoft.Conversion Namespace | TypeCaster.double_cast Overload List

Copyright © Synesis Software Pty Ltd, 2002-2003

Generated from assembly SynSoft.NET.Conv [1.0.1279.28854]


float_cast Method

SynSoft .NET Libraries (release 3rd July 2003)

TypeCaster.float_cast Method

Casts to a float

Overload List

Casts to a float

public static float float_cast(float);

Casts to a float

public static float float_cast(object);

See Also

TypeCaster Class | TypeCaster Members | SynSoft.Conversion Namespace

Copyright © Synesis Software Pty Ltd, 2002-2003

Generated from assembly SynSoft.NET.Conv [1.0.1279.28854]


TypeCaster.float_cast Method (Object)

Casts to a float

[Visual Basic]
Overloads Public Shared Function float_cast( _
   ByVal v As Object _
) As Single
[C#]
public static float float_cast(
object v
);

Parameters

v
The value to cast from

Return Value

See Also

TypeCaster Class | TypeCaster Members | SynSoft.Conversion Namespace | TypeCaster.float_cast Overload List

Copyright © Synesis Software Pty Ltd, 2002-2003

Generated from assembly SynSoft.NET.Conv [1.0.1279.28854]


TypeCaster.float_cast Method (Single)

Casts to a float

[Visual Basic]
Overloads Public Shared Function float_cast( _
   ByVal v As Single _
) As Single
[C#]
public static float float_cast(
float v
);

Parameters

v
The value to cast from

Return Value

See Also

TypeCaster Class | TypeCaster Members | SynSoft.Conversion Namespace | TypeCaster.float_cast Overload List

Copyright © Synesis Software Pty Ltd, 2002-2003

Generated from assembly SynSoft.NET.Conv [1.0.1279.28854]


int_cast Method

SynSoft .NET Libraries (release 3rd July 2003)

TypeCaster.int_cast Method

Casts to a int

Overload List

Casts to a int

public static int int_cast(int);

Casts to a int

public static int int_cast(short);

Casts to a int

public static int int_cast(sbyte);

Casts to a int

public static int int_cast(object,bool);

Casts to a int, disallowing conversion from unsigned types

public static int int_cast(object);

See Also

TypeCaster Class | TypeCaster Members | SynSoft.Conversion Namespace

Copyright © Synesis Software Pty Ltd, 2002-2003

Generated from assembly SynSoft.NET.Conv [1.0.1279.28854]


TypeCaster.int_cast Method (Int16)

Casts to a int

[Visual Basic]
Overloads Public Shared Function int_cast( _
   ByVal v As Short _
) As Integer
[C#]
public static int int_cast(
short v
);

Parameters

v
The value to cast from

Return Value

See Also

TypeCaster Class | TypeCaster Members | SynSoft.Conversion Namespace | TypeCaster.int_cast Overload List

Copyright © Synesis Software Pty Ltd, 2002-2003

Generated from assembly SynSoft.NET.Conv [1.0.1279.28854]


TypeCaster.int_cast Method (Int32)

Casts to a int

[Visual Basic]
Overloads Public Shared Function int_cast( _
   ByVal v As Integer _
) As Integer
[C#]
public static int int_cast(
int v
);

Parameters

v
The value to cast from

Return Value

See Also

TypeCaster Class | TypeCaster Members | SynSoft.Conversion Namespace | TypeCaster.int_cast Overload List

Copyright © Synesis Software Pty Ltd, 2002-2003

Generated from assembly SynSoft.NET.Conv [1.0.1279.28854]


TypeCaster.int_cast Method (Object)

Casts to a int, disallowing conversion from unsigned types

[Visual Basic]
Overloads Public Shared Function int_cast( _
   ByVal v As Object _
) As Integer
[C#]
public static int int_cast(
object v
);

Parameters

v
The value to cast from

Return Value

See Also

TypeCaster Class | TypeCaster Members | SynSoft.Conversion Namespace | TypeCaster.int_cast Overload List

Copyright © Synesis Software Pty Ltd, 2002-2003

Generated from assembly SynSoft.NET.Conv [1.0.1279.28854]


TypeCaster.int_cast Method (Object, Boolean)

Casts to a int

[Visual Basic]
Overloads Public Shared Function int_cast( _
   ByVal v As Object, _
   ByVal bAcceptUnsigned As Boolean _
) As Integer
[C#]
public static int int_cast(
object v,
bool bAcceptUnsigned
);

Parameters

v
The value to cast from
bAcceptUnsigned
Determines whether conversion from unsigned types will be attempted

Return Value

See Also

TypeCaster Class | TypeCaster Members | SynSoft.Conversion Namespace | TypeCaster.int_cast Overload List

Copyright © Synesis Software Pty Ltd, 2002-2003

Generated from assembly SynSoft.NET.Conv [1.0.1279.28854]


TypeCaster.int_cast Method (SByte)

Casts to a int

[Visual Basic]
Overloads Public Shared Function int_cast( _
   ByVal v As SByte _
) As Integer
[C#]
public static int int_cast(
sbyte v
);

Parameters

v
The value to cast from

Return Value

See Also

TypeCaster Class | TypeCaster Members | SynSoft.Conversion Namespace | TypeCaster.int_cast Overload List

Copyright © Synesis Software Pty Ltd, 2002-2003

Generated from assembly SynSoft.NET.Conv [1.0.1279.28854]


long_cast Method

SynSoft .NET Libraries (release 3rd July 2003)

TypeCaster.long_cast Method

Casts to a long

Overload List

Casts to a long

public static long long_cast(long);

Casts to a long

public static long long_cast(int);

Casts to a long

public static long long_cast(short);

Casts to a long

public static long long_cast(sbyte);

Casts to a long

public static long long_cast(object,bool);

Casts to a long, disallowing conversion from unsigned types

public static long long_cast(object);

See Also

TypeCaster Class | TypeCaster Members | SynSoft.Conversion Namespace

Copyright © Synesis Software Pty Ltd, 2002-2003

Generated from assembly SynSoft.NET.Conv [1.0.1279.28854]


TypeCaster.long_cast Method (Int16)

Casts to a long

[Visual Basic]
Overloads Public Shared Function long_cast( _
   ByVal v As Short _
) As Long
[C#]
public static long long_cast(
short v
);

Parameters

v
The value to cast from

Return Value

See Also

TypeCaster Class | TypeCaster Members | SynSoft.Conversion Namespace | TypeCaster.long_cast Overload List

Copyright © Synesis Software Pty Ltd, 2002-2003

Generated from assembly SynSoft.NET.Conv [1.0.1279.28854]


TypeCaster.long_cast Method (Int32)

Casts to a long

[Visual Basic]
Overloads Public Shared Function long_cast( _
   ByVal v As Integer _
) As Long
[C#]
public static long long_cast(
int v
);

Parameters

v
The value to cast from

Return Value

See Also

TypeCaster Class | TypeCaster Members | SynSoft.Conversion Namespace | TypeCaster.long_cast Overload List

Copyright © Synesis Software Pty Ltd, 2002-2003

Generated from assembly SynSoft.NET.Conv [1.0.1279.28854]


TypeCaster.long_cast Method (Int64)

Casts to a long

[Visual Basic]
Overloads Public Shared Function long_cast( _
   ByVal v As Long _
) As Long
[C#]
public static long long_cast(
long v
);

Parameters

v
The value to cast from

Return Value

See Also

TypeCaster Class | TypeCaster Members | SynSoft.Conversion Namespace | TypeCaster.long_cast Overload List

Copyright © Synesis Software Pty Ltd, 2002-2003

Generated from assembly SynSoft.NET.Conv [1.0.1279.28854]


TypeCaster.long_cast Method (Object)

Casts to a long, disallowing conversion from unsigned types

[Visual Basic]
Overloads Public Shared Function long_cast( _
   ByVal v As Object _
) As Long
[C#]
public static long long_cast(
object v
);

Parameters

v
The value to cast from

Return Value

See Also

TypeCaster Class | TypeCaster Members | SynSoft.Conversion Namespace | TypeCaster.long_cast Overload List

Copyright © Synesis Software Pty Ltd, 2002-2003

Generated from assembly SynSoft.NET.Conv [1.0.1279.28854]


TypeCaster.long_cast Method (Object, Boolean)

Casts to a long

[Visual Basic]
Overloads Public Shared Function long_cast( _
   ByVal v As Object, _
   ByVal bAcceptUnsigned As Boolean _
) As Long
[C#]
public static long long_cast(
object v,
bool bAcceptUnsigned
);

Parameters

v
The value to cast from
bAcceptUnsigned
Determines whether conversion from unsigned types will be attempted

Return Value

See Also

TypeCaster Class | TypeCaster Members | SynSoft.Conversion Namespace | TypeCaster.long_cast Overload List

Copyright © Synesis Software Pty Ltd, 2002-2003

Generated from assembly SynSoft.NET.Conv [1.0.1279.28854]


TypeCaster.long_cast Method (SByte)

Casts to a long

[Visual Basic]
Overloads Public Shared Function long_cast( _
   ByVal v As SByte _
) As Long
[C#]
public static long long_cast(
sbyte v
);

Parameters

v
The value to cast from

Return Value

See Also

TypeCaster Class | TypeCaster Members | SynSoft.Conversion Namespace | TypeCaster.long_cast Overload List

Copyright © Synesis Software Pty Ltd, 2002-2003

Generated from assembly SynSoft.NET.Conv [1.0.1279.28854]


sbyte_cast Method

SynSoft .NET Libraries (release 3rd July 2003)

TypeCaster.sbyte_cast Method

Casts to a sbyte, disallowing conversion from unsigned types

Overload List

Casts to a sbyte

public static sbyte sbyte_cast(sbyte);

Casts to a sbyte

public static sbyte sbyte_cast(object,bool);

Casts to a sbyte, disallowing conversion from unsigned types

public static sbyte sbyte_cast(object);

See Also

TypeCaster Class | TypeCaster Members | SynSoft.Conversion Namespace

Copyright © Synesis Software Pty Ltd, 2002-2003

Generated from assembly SynSoft.NET.Conv [1.0.1279.28854]


TypeCaster.sbyte_cast Method (Object)

Casts to a sbyte, disallowing conversion from unsigned types

[Visual Basic]
Overloads Public Shared Function sbyte_cast( _
   ByVal v As Object _
) As SByte
[C#]
public static sbyte sbyte_cast(
object v
);

Parameters

v
The value to cast from

Return Value

See Also

TypeCaster Class | TypeCaster Members | SynSoft.Conversion Namespace | TypeCaster.sbyte_cast Overload List

Copyright © Synesis Software Pty Ltd, 2002-2003

Generated from assembly SynSoft.NET.Conv [1.0.1279.28854]


TypeCaster.sbyte_cast Method (Object, Boolean)

Casts to a sbyte

[Visual Basic]
Overloads Public Shared Function sbyte_cast( _
   ByVal v As Object, _
   ByVal bAcceptUnsigned As Boolean _
) As SByte
[C#]
public static sbyte sbyte_cast(
object v,
bool bAcceptUnsigned
);

Parameters

v
The value to cast from
bAcceptUnsigned
Determines whether conversion from unsigned types will be attempted

Return Value

See Also

TypeCaster Class | TypeCaster Members | SynSoft.Conversion Namespace | TypeCaster.sbyte_cast Overload List

Copyright © Synesis Software Pty Ltd, 2002-2003

Generated from assembly SynSoft.NET.Conv [1.0.1279.28854]


TypeCaster.sbyte_cast Method (SByte)

Casts to a sbyte

[Visual Basic]
Overloads Public Shared Function sbyte_cast( _
   ByVal v As SByte _
) As SByte
[C#]
public static sbyte sbyte_cast(
sbyte v
);

Parameters

v
The value to cast from

Return Value

See Also

TypeCaster Class | TypeCaster Members | SynSoft.Conversion Namespace | TypeCaster.sbyte_cast Overload List

Copyright © Synesis Software Pty Ltd, 2002-2003

Generated from assembly SynSoft.NET.Conv [1.0.1279.28854]


short_cast Method

SynSoft .NET Libraries (release 3rd July 2003)

TypeCaster.short_cast Method

Casts to a short

Overload List

Casts to a short

public static short short_cast(short);

Casts to a sbyte

public static short short_cast(sbyte);

Casts to a short

public static short short_cast(object,bool);

Casts to a short, disallowing conversion from unsigned types

public static short short_cast(object);

See Also

TypeCaster Class | TypeCaster Members | SynSoft.Conversion Namespace

Copyright © Synesis Software Pty Ltd, 2002-2003

Generated from assembly SynSoft.NET.Conv [1.0.1279.28854]


TypeCaster.short_cast Method (Int16)

Casts to a short

[Visual Basic]
Overloads Public Shared Function short_cast( _
   ByVal v As Short _
) As Short
[C#]
public static short short_cast(
short v
);

Parameters

v
The value to cast from

Return Value

See Also

TypeCaster Class | TypeCaster Members | SynSoft.Conversion Namespace | TypeCaster.short_cast Overload List

Copyright © Synesis Software Pty Ltd, 2002-2003

Generated from assembly SynSoft.NET.Conv [1.0.1279.28854]


TypeCaster.short_cast Method (Object)

Casts to a short, disallowing conversion from unsigned types

[Visual Basic]
Overloads Public Shared Function short_cast( _
   ByVal v As Object _
) As Short
[C#]
public static short short_cast(
object v
);

Parameters

v
The value to cast from

Return Value

See Also

TypeCaster Class | TypeCaster Members | SynSoft.Conversion Namespace | TypeCaster.short_cast Overload List

Copyright © Synesis Software Pty Ltd, 2002-2003

Generated from assembly SynSoft.NET.Conv [1.0.1279.28854]


TypeCaster.short_cast Method (Object, Boolean)

Casts to a short

[Visual Basic]
Overloads Public Shared Function short_cast( _
   ByVal v As Object, _
   ByVal bAcceptUnsigned As Boolean _
) As Short
[C#]
public static short short_cast(
object v,
bool bAcceptUnsigned
);

Parameters

v
The value to cast from
bAcceptUnsigned
Determines whether conversion from unsigned types will be attempted

Return Value

See Also

TypeCaster Class | TypeCaster Members | SynSoft.Conversion Namespace | TypeCaster.short_cast Overload List

Copyright © Synesis Software Pty Ltd, 2002-2003

Generated from assembly SynSoft.NET.Conv [1.0.1279.28854]


TypeCaster.short_cast Method (SByte)

Casts to a sbyte

[Visual Basic]
Overloads Public Shared Function short_cast( _
   ByVal v As SByte _
) As Short
[C#]
public static short short_cast(
sbyte v
);

Parameters

v
The value to cast from

Return Value

See Also

TypeCaster Class | TypeCaster Members | SynSoft.Conversion Namespace | TypeCaster.short_cast Overload List

Copyright © Synesis Software Pty Ltd, 2002-2003

Generated from assembly SynSoft.NET.Conv [1.0.1279.28854]


uint_cast Method

SynSoft .NET Libraries (release 3rd July 2003)

TypeCaster.uint_cast Method

Casts to a uint

Overload List

Casts to a uint

public static uint uint_cast(uint);

Casts to a uint

public static uint uint_cast(ushort);

Casts to a uint

public static uint uint_cast(byte);

Casts to a uint

public static uint uint_cast(object,bool);

Casts to a uint, disallowing conversion from signed types

public static uint uint_cast(object);

See Also

TypeCaster Class | TypeCaster Members | SynSoft.Conversion Namespace

Copyright © Synesis Software Pty Ltd, 2002-2003

Generated from assembly SynSoft.NET.Conv [1.0.1279.28854]


TypeCaster.uint_cast Method (Byte)

Casts to a uint

[Visual Basic]
Overloads Public Shared Function uint_cast( _
   ByVal v As Byte _
) As UInt32
[C#]
public static uint uint_cast(
byte v
);

Parameters

v
The value to cast from

Return Value

See Also

TypeCaster Class | TypeCaster Members | SynSoft.Conversion Namespace | TypeCaster.uint_cast Overload List

Copyright © Synesis Software Pty Ltd, 2002-2003

Generated from assembly SynSoft.NET.Conv [1.0.1279.28854]


TypeCaster.uint_cast Method (Object)

Casts to a uint, disallowing conversion from signed types

[Visual Basic]
Overloads Public Shared Function uint_cast( _
   ByVal v As Object _
) As UInt32
[C#]
public static uint uint_cast(
object v
);

Parameters

v
The value to cast from

Return Value

See Also

TypeCaster Class | TypeCaster Members | SynSoft.Conversion Namespace | TypeCaster.uint_cast Overload List

Copyright © Synesis Software Pty Ltd, 2002-2003

Generated from assembly SynSoft.NET.Conv [1.0.1279.28854]


TypeCaster.uint_cast Method (Object, Boolean)

Casts to a uint

[Visual Basic]
Overloads Public Shared Function uint_cast( _
   ByVal v As Object, _
   ByVal bAcceptSigned As Boolean _
) As UInt32
[C#]
public static uint uint_cast(
object v,
bool bAcceptSigned
);

Parameters

v
The value to cast from
bAcceptSigned
Determines whether conversion from signed types will be attempted

Return Value

See Also

TypeCaster Class | TypeCaster Members | SynSoft.Conversion Namespace | TypeCaster.uint_cast Overload List

Copyright © Synesis Software Pty Ltd, 2002-2003

Generated from assembly SynSoft.NET.Conv [1.0.1279.28854]


TypeCaster.uint_cast Method (UInt16)

Casts to a uint

[Visual Basic]
Overloads Public Shared Function uint_cast( _
   ByVal v As UInt16 _
) As UInt32
[C#]
public static uint uint_cast(
ushort v
);

Parameters

v
The value to cast from

Return Value

See Also

TypeCaster Class | TypeCaster Members | SynSoft.Conversion Namespace | TypeCaster.uint_cast Overload List

Copyright © Synesis Software Pty Ltd, 2002-2003

Generated from assembly SynSoft.NET.Conv [1.0.1279.28854]


TypeCaster.uint_cast Method (UInt32)

Casts to a uint

[Visual Basic]
Overloads Public Shared Function uint_cast( _
   ByVal v As UInt32 _
) As UInt32
[C#]
public static uint uint_cast(
uint v
);

Parameters

v
The value to cast from

Return Value

See Also

TypeCaster Class | TypeCaster Members | SynSoft.Conversion Namespace | TypeCaster.uint_cast Overload List

Copyright © Synesis Software Pty Ltd, 2002-2003

Generated from assembly SynSoft.NET.Conv [1.0.1279.28854]


ulong_cast Method

SynSoft .NET Libraries (release 3rd July 2003)

TypeCaster.ulong_cast Method

Casts to a ulong

Overload List

Casts to a ulong

public static ulong ulong_cast(ulong);

Casts to a ulong

public static ulong ulong_cast(uint);

Casts to a ulong

public static ulong ulong_cast(ushort);

Casts to a ulong

public static ulong ulong_cast(byte);

Casts to a ulong

public static ulong ulong_cast(object,bool);

Casts to a ulong, disallowing conversion from signed types

public static ulong ulong_cast(object);

See Also

TypeCaster Class | TypeCaster Members | SynSoft.Conversion Namespace

Copyright © Synesis Software Pty Ltd, 2002-2003

Generated from assembly SynSoft.NET.Conv [1.0.1279.28854]


TypeCaster.ulong_cast Method (Byte)

Casts to a ulong

[Visual Basic]
Overloads Public Shared Function ulong_cast( _
   ByVal v As Byte _
) As UInt64
[C#]
public static ulong ulong_cast(
byte v
);

Parameters

v
The value to cast from

Return Value

See Also

TypeCaster Class | TypeCaster Members | SynSoft.Conversion Namespace | TypeCaster.ulong_cast Overload List

Copyright © Synesis Software Pty Ltd, 2002-2003

Generated from assembly SynSoft.NET.Conv [1.0.1279.28854]


TypeCaster.ulong_cast Method (Object)

Casts to a ulong, disallowing conversion from signed types

[Visual Basic]
Overloads Public Shared Function ulong_cast( _
   ByVal v As Object _
) As UInt64
[C#]
public static ulong ulong_cast(
object v
);

Parameters

v
The value to cast from

Return Value

See Also

TypeCaster Class | TypeCaster Members | SynSoft.Conversion Namespace | TypeCaster.ulong_cast Overload List

Copyright © Synesis Software Pty Ltd, 2002-2003

Generated from assembly SynSoft.NET.Conv [1.0.1279.28854]


TypeCaster.ulong_cast Method (Object, Boolean)

Casts to a ulong

[Visual Basic]
Overloads Public Shared Function ulong_cast( _
   ByVal v As Object, _
   ByVal bAcceptSigned As Boolean _
) As UInt64
[C#]
public static ulong ulong_cast(
object v,
bool bAcceptSigned
);

Parameters

v
The value to cast from
bAcceptSigned
Determines whether conversion from signed types will be attempted

Return Value

See Also

TypeCaster Class | TypeCaster Members | SynSoft.Conversion Namespace | TypeCaster.ulong_cast Overload List

Copyright © Synesis Software Pty Ltd, 2002-2003

Generated from assembly SynSoft.NET.Conv [1.0.1279.28854]


TypeCaster.ulong_cast Method (UInt16)

Casts to a ulong

[Visual Basic]
Overloads Public Shared Function ulong_cast( _
   ByVal v As UInt16 _
) As UInt64
[C#]
public static ulong ulong_cast(
ushort v
);

Parameters

v
The value to cast from

Return Value

See Also

TypeCaster Class | TypeCaster Members | SynSoft.Conversion Namespace | TypeCaster.ulong_cast Overload List

Copyright © Synesis Software Pty Ltd, 2002-2003

Generated from assembly SynSoft.NET.Conv [1.0.1279.28854]


TypeCaster.ulong_cast Method (UInt32)

Casts to a ulong

[Visual Basic]
Overloads Public Shared Function ulong_cast( _
   ByVal v As UInt32 _
) As UInt64
[C#]
public static ulong ulong_cast(
uint v
);

Parameters

v
The value to cast from

Return Value

See Also

TypeCaster Class | TypeCaster Members | SynSoft.Conversion Namespace | TypeCaster.ulong_cast Overload List

Copyright © Synesis Software Pty Ltd, 2002-2003

Generated from assembly SynSoft.NET.Conv [1.0.1279.28854]


TypeCaster.ulong_cast Method (UInt64)

Casts to a ulong

[Visual Basic]
Overloads Public Shared Function ulong_cast( _
   ByVal v As UInt64 _
) As UInt64
[C#]
public static ulong ulong_cast(
ulong v
);

Parameters

v
The value to cast from

Return Value

See Also

TypeCaster Class | TypeCaster Members | SynSoft.Conversion Namespace | TypeCaster.ulong_cast Overload List

Copyright © Synesis Software Pty Ltd, 2002-2003

Generated from assembly SynSoft.NET.Conv [1.0.1279.28854]


ushort_cast Method

SynSoft .NET Libraries (release 3rd July 2003)

TypeCaster.ushort_cast Method

Casts to a ushort

Overload List

Casts to a ushort

public static ushort ushort_cast(ushort);

Casts to a ushort

public static ushort ushort_cast(byte);

Casts to a ushort

public static ushort ushort_cast(object,bool);

Casts to a ushort, disallowing conversion from signed types

public static ushort ushort_cast(object);

See Also

TypeCaster Class | TypeCaster Members | SynSoft.Conversion Namespace

Copyright © Synesis Software Pty Ltd, 2002-2003

Generated from assembly SynSoft.NET.Conv [1.0.1279.28854]


TypeCaster.ushort_cast Method (Byte)

Casts to a ushort

[Visual Basic]
Overloads Public Shared Function ushort_cast( _
   ByVal v As Byte _
) As UInt16
[C#]
public static ushort ushort_cast(
byte v
);

Parameters

v
The value to cast from

Return Value

See Also

TypeCaster Class | TypeCaster Members | SynSoft.Conversion Namespace | TypeCaster.ushort_cast Overload List

Copyright © Synesis Software Pty Ltd, 2002-2003

Generated from assembly SynSoft.NET.Conv [1.0.1279.28854]


TypeCaster.ushort_cast Method (Object)

Casts to a ushort, disallowing conversion from signed types

[Visual Basic]
Overloads Public Shared Function ushort_cast( _
   ByVal v As Object _
) As UInt16
[C#]
public static ushort ushort_cast(
object v
);

Parameters

v
The value to cast from

Return Value

See Also

TypeCaster Class | TypeCaster Members | SynSoft.Conversion Namespace | TypeCaster.ushort_cast Overload List

Copyright © Synesis Software Pty Ltd, 2002-2003

Generated from assembly SynSoft.NET.Conv [1.0.1279.28854]


TypeCaster.ushort_cast Method (Object, Boolean)

Casts to a ushort

[Visual Basic]
Overloads Public Shared Function ushort_cast( _
   ByVal v As Object, _
   ByVal bAcceptSigned As Boolean _
) As UInt16
[C#]
public static ushort ushort_cast(
object v,
bool bAcceptSigned
);

Parameters

v
The value to cast from
bAcceptSigned
Determines whether conversion from signed types will be attempted

Return Value

See Also

TypeCaster Class | TypeCaster Members | SynSoft.Conversion Namespace | TypeCaster.ushort_cast Overload List

Copyright © Synesis Software Pty Ltd, 2002-2003

Generated from assembly SynSoft.NET.Conv [1.0.1279.28854]


TypeCaster.ushort_cast Method (UInt16)

Casts to a ushort

[Visual Basic]
Overloads Public Shared Function ushort_cast( _
   ByVal v As UInt16 _
) As UInt16
[C#]
public static ushort ushort_cast(
ushort v
);

Parameters

v
The value to cast from

Return Value

See Also

TypeCaster Class | TypeCaster Members | SynSoft.Conversion Namespace | TypeCaster.ushort_cast Overload List

Copyright © Synesis Software Pty Ltd, 2002-2003

Generated from assembly SynSoft.NET.Conv [1.0.1279.28854]


TypeCastException Class

This class is thrown to indicate a type-cast failure

For a list of all members of this type, see TypeCastException Members.

System.Object
Exception
TypeCastException

[Visual Basic]
Public Class TypeCastException
Inherits Exception
[C#]
public class TypeCastException : Exception

Requirements

Namespace: SynSoft.Conversion Namespace

Assembly: SynSoft.NET.Conv.dll

See Also

TypeCastException Members | SynSoft.Conversion Namespace

Copyright © Synesis Software Pty Ltd, 2002-2003

Generated from assembly SynSoft.NET.Conv [1.0.1279.28854]


TypeCastException Members

Public Instance Constructors

TypeCastException Overloaded. Initialize a new instance of the TypeCastException class.

Public Instance Properties

From | The type from which cast was attempted
HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
Message (inherited from Exception) | Gets a message that describes the current exception.
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.
To | The type to which cast was attempted

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Exception) | Creates and returns a string representation of the current exception.

Protected Instance Fields

m_typeFrom | The type from which casting was attempted
m_typeTo | The type to which casting was attempted

Protected Instance Properties

HResult (inherited from Exception) Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

TypeCastException Class | SynSoft.Conversion Namespace

Copyright © Synesis Software Pty Ltd, 2002-2003

Generated from assembly SynSoft.NET.Conv [1.0.1279.28854]


TypeCastException Constructor

Constructs from the from and to types.

Overload List

Constructs from the from and to types.

public TypeCastException(Type,Type);

Constructs from the from and to types, and a specific reason for the failure.

public TypeCastException(Type,Type,string);

See Also

TypeCastException Class | TypeCastException Members | SynSoft.Conversion Namespace

Copyright © Synesis Software Pty Ltd, 2002-2003

Generated from assembly SynSoft.NET.Conv [1.0.1279.28854]


TypeCastException Constructor (Type, Type)

Constructs from the from and to types.

[Visual Basic]
Overloads Public Sub New( _
   ByVal from As Type, _
   ByVal to As Type _
)
[C#]
public TypeCastException(
Type from,
Type to
);

Parameters

from
The type from which casting was attempted
to
The type to which casting was attempted

See Also

TypeCastException Class | TypeCastException Members | SynSoft.Conversion Namespace | TypeCastException Constructor Overload List

Copyright © Synesis Software Pty Ltd, 2002-2003

Generated from assembly SynSoft.NET.Conv [1.0.1279.28854]


TypeCastException Constructor (Type, Type, String)

Constructs from the from and to types, and a specific reason for the failure.

[Visual Basic]
Overloads Public Sub New( _
   ByVal from As Type, _
   ByVal to As Type, _
   ByVal reason As String _
)
[C#]
public TypeCastException(
Type from,
Type to,
string reason
);

Parameters

from
The type from which casting was attempted
to
The type to which casting was attempted
reason
The reason that the cast failed

See Also

TypeCastException Class | TypeCastException Members | SynSoft.Conversion Namespace | TypeCastException Constructor Overload List

Copyright © Synesis Software Pty Ltd, 2002-2003

Generated from assembly SynSoft.NET.Conv [1.0.1279.28854]


TypeCastException Fields

The fields of the TypeCastException class are listed below. For a complete list of TypeCastException class members, see the TypeCastException Members topic.

Protected Instance Fields

m_typeFrom | The type from which casting was attempted
m_typeTo | The type to which casting was attempted

See Also

TypeCastException Class | SynSoft.Conversion Namespace

Copyright © Synesis Software Pty Ltd, 2002-2003

Generated from assembly SynSoft.NET.Conv [1.0.1279.28854]


TypeCastException.m_typeFrom Field

The type from which casting was attempted

[Visual Basic]
Protected ReadOnly m_typeFrom As Type
[C#]
protected readonly Type m_typeFrom;

See Also

TypeCastException Class | TypeCastException Members | SynSoft.Conversion Namespace

Copyright © Synesis Software Pty Ltd, 2002-2003

Generated from assembly SynSoft.NET.Conv [1.0.1279.28854]


TypeCastException.m_typeTo Field

The type to which casting was attempted

[Visual Basic]
Protected ReadOnly m_typeTo As Type
[C#]
protected readonly Type m_typeTo;

See Also

TypeCastException Class | TypeCastException Members | SynSoft.Conversion Namespace

Copyright © Synesis Software Pty Ltd, 2002-2003

Generated from assembly SynSoft.NET.Conv [1.0.1279.28854]


TypeCastException Properties

The properties of the TypeCastException class are listed below. For a complete list of TypeCastException class members, see the TypeCastException Members topic.

Public Instance Properties

From | The type from which cast was attempted
HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
Message (inherited from Exception) | Gets a message that describes the current exception.
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.
To | The type to which cast was attempted

Protected Instance Properties

HResult (inherited from Exception) Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception.

See Also

TypeCastException Class | SynSoft.Conversion Namespace

Copyright © Synesis Software Pty Ltd, 2002-2003

Generated from assembly SynSoft.NET.Conv [1.0.1279.28854]


TypeCastException.From Property

The type from which cast was attempted

[Visual Basic]
Public ReadOnly Property From As Type
[C#]
public System.Type From {get;}

See Also

TypeCastException Class | TypeCastException Members | SynSoft.Conversion Namespace

Copyright © Synesis Software Pty Ltd, 2002-2003

Generated from assembly SynSoft.NET.Conv [1.0.1279.28854]


TypeCastException.To Property

The type to which cast was attempted

[Visual Basic]
Public ReadOnly Property To As Type
[C#]
public System.Type To {get;}

See Also

TypeCastException Class | TypeCastException Members | SynSoft.Conversion Namespace

Copyright © Synesis Software Pty Ltd, 2002-2003

Generated from assembly SynSoft.NET.Conv [1.0.1279.28854]


SynSoft.Performance

SynSoft .NET Libraries (release 3rd July 2003)

SynSoft.Performance Namespace

Classes

Class | Description
HighPerformanceCounter | Performance counter based on the system high-performance counter
PerformanceCounter | Performance counter based on the best available system counter
ProcessTimesCounter | Process-specific performance counter
ThreadTimesCounter | Thread-specific performance counter
TickCounter | Performance counter based on the system Tick counter


HighPerformanceCounter Class

Performance counter based on the system high-performance counter

For a list of all members of this type, see HighPerformanceCounter Members.

System.Object
HighPerformanceCounter

[Visual Basic]
NotInheritable Public Class HighPerformanceCounter
[C#]
public sealed class HighPerformanceCounter

Requirements

Namespace: SynSoft.Performance Namespace

Assembly: SynSoft.NET.Perf.dll

See Also

HighPerformanceCounter Members | SynSoft.Performance Namespace

Copyright © Synesis Software Pty Ltd, 2002-2003

Generated from assembly SynSoft.NET.Perf [1.0.1279.28854]


HighPerformanceCounter Members

Public Instance Constructors

HighPerformanceCounter Constructor Initializes a new instance of the HighPerformanceCounter class.

Public Instance Properties

MicroSeconds | The number of microseconds recorded
MilliSeconds | The number of milliseconds recorded
PeriodCount | The elapsed interval (in machine-specific increments)
Seconds | The number of seconds recorded

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Start | Begins the measurement interval
Stop | Ends the measurement interval
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

HighPerformanceCounter Class | SynSoft.Performance Namespace

Copyright © Synesis Software Pty Ltd, 2002-2003

Generated from assembly SynSoft.NET.Perf [1.0.1279.28854]


HighPerformanceCounter Constructor

Initializes a new instance of the HighPerformanceCounter class.

[Visual Basic]
Public Sub New()
[C#]
public HighPerformanceCounter();

See Also

HighPerformanceCounter Class | HighPerformanceCounter Members | SynSoft.Performance Namespace

Copyright © Synesis Software Pty Ltd, 2002-2003

Generated from assembly SynSoft.NET.Perf [1.0.1279.28854]


HighPerformanceCounter Properties

The properties of the HighPerformanceCounter class are listed below. For a complete list of HighPerformanceCounter class members, see the HighPerformanceCounter Members topic.

Public Instance Properties

MicroSeconds | The number of microseconds recorded
MilliSeconds | The number of milliseconds recorded
PeriodCount | The elapsed interval (in machine-specific increments)
Seconds | The number of seconds recorded

See Also

HighPerformanceCounter Class | SynSoft.Performance Namespace

Copyright © Synesis Software Pty Ltd, 2002-2003

Generated from assembly SynSoft.NET.Perf [1.0.1279.28854]


HighPerformanceCounter.MicroSeconds Property

The number of microseconds recorded

[Visual Basic]
Public ReadOnly Property MicroSeconds As Long
[C#]
public long MicroSeconds {get;}

See Also

HighPerformanceCounter Class | HighPerformanceCounter Members | SynSoft.Performance Namespace

Copyright © Synesis Software Pty Ltd, 2002-2003

Generated from assembly SynSoft.NET.Perf [1.0.1279.28854]


HighPerformanceCounter.MilliSeconds Property

The number of milliseconds recorded

[Visual Basic]
Public ReadOnly Property MilliSeconds As Long
[C#]
public long MilliSeconds {get;}

See Also

HighPerformanceCounter Class | HighPerformanceCounter Members | SynSoft.Performance Namespace

Copyright © Synesis Software Pty Ltd, 2002-2003

Generated from assembly SynSoft.NET.Perf [1.0.1279.28854]


HighPerformanceCounter.PeriodCount Property

The elapsed interval (in machine-specific increments)

[Visual Basic]
Public ReadOnly Property PeriodCount As Long
[C#]
public long PeriodCount {get;}

See Also

HighPerformanceCounter Class | HighPerformanceCounter Members | SynSoft.Performance Namespace

Copyright © Synesis Software Pty Ltd, 2002-2003

Generated from assembly SynSoft.NET.Perf [1.0.1279.28854]


HighPerformanceCounter.Seconds Property

The number of seconds recorded

[Visual Basic]
Public ReadOnly Property Seconds As Long
[C#]
public long Seconds {get;}

See Also

HighPerformanceCounter Class | HighPerformanceCounter Members | SynSoft.Performance Namespace

Copyright © Synesis Software Pty Ltd, 2002-2003

Generated from assembly SynSoft.NET.Perf [1.0.1279.28854]


HighPerformanceCounter Methods

The methods of the HighPerformanceCounter class are listed below. For a complete list of HighPerformanceCounter class members, see the HighPerformanceCounter Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Start | Begins the measurement interval
Stop | Ends the measurement interval
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

HighPerformanceCounter Class | SynSoft.Performance Namespace

Copyright © Synesis Software Pty Ltd, 2002-2003

Generated from assembly SynSoft.NET.Perf [1.0.1279.28854]


HighPerformanceCounter.Start Method

Begins the measurement interval

[Visual Basic]
Public Sub Start()
[C#]
public void Start();

See Also

HighPerformanceCounter Class | HighPerformanceCounter Members | SynSoft.Performance Namespace

Copyright © Synesis Software Pty Ltd, 2002-2003

Generated from assembly SynSoft.NET.Perf [1.0.1279.28854]


HighPerformanceCounter.Stop Method

Ends the measurement interval

[Visual Basic]
Public Sub Stop()
[C#]
public void Stop();

See Also

HighPerformanceCounter Class | HighPerformanceCounter Members | SynSoft.Performance Namespace

Copyright © Synesis Software Pty Ltd, 2002-2003

Generated from assembly SynSoft.NET.Perf [1.0.1279.28854]


PerformanceCounter Class

Performance counter based on the best available system counter

For a list of all members of this type, see PerformanceCounter Members.

System.Object
PerformanceCounter

[Visual Basic]
NotInheritable Public Class PerformanceCounter
[C#]
public sealed class PerformanceCounter

Requirements

Namespace: SynSoft.Performance Namespace

Assembly: SynSoft.NET.Perf.dll

See Also

PerformanceCounter Members | SynSoft.Performance Namespace

Copyright © Synesis Software Pty Ltd, 2002-2003

Generated from assembly SynSoft.NET.Perf [1.0.1279.28854]


PerformanceCounter Members

Public Instance Constructors

PerformanceCounter Constructor Initializes a new instance of the PerformanceCounter class.

Public Instance Properties

MicroSeconds | The number of microseconds recorded
MilliSeconds | The number of milliseconds recorded
PeriodCount | The elapsed interval (in machine-specific increments)
Seconds | The number of seconds recorded

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Start | Begins the measurement interval
Stop | Ends the measurement interval
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

PerformanceCounter Class | SynSoft.Performance Namespace

Copyright © Synesis Software Pty Ltd, 2002-2003

Generated from assembly SynSoft.NET.Perf [1.0.1279.28854]


PerformanceCounter Constructor

Initializes a new instance of the PerformanceCounter class.

[Visual Basic]
Public Sub New()
[C#]
public PerformanceCounter();

See Also

PerformanceCounter Class | PerformanceCounter Members | SynSoft.Performance Namespace

Copyright © Synesis Software Pty Ltd, 2002-2003

Generated from assembly SynSoft.NET.Perf [1.0.1279.28854]


PerformanceCounter Properties

The properties of the PerformanceCounter class are listed below. For a complete list of PerformanceCounter class members, see the PerformanceCounter Members topic.

Public Instance Properties

MicroSeconds | The number of microseconds recorded
MilliSeconds | The number of milliseconds recorded
PeriodCount | The elapsed interval (in machine-specific increments)
Seconds | The number of seconds recorded

See Also

PerformanceCounter Class | SynSoft.Performance Namespace

Copyright © Synesis Software Pty Ltd, 2002-2003

Generated from assembly SynSoft.NET.Perf [1.0.1279.28854]


PerformanceCounter.MicroSeconds Property

The number of microseconds recorded

[Visual Basic]
Public ReadOnly Property MicroSeconds As Long
[C#]
public long MicroSeconds {get;}

See Also

PerformanceCounter Class | PerformanceCounter Members | SynSoft.Performance Namespace

Copyright © Synesis Software Pty Ltd, 2002-2003

Generated from assembly SynSoft.NET.Perf [1.0.1279.28854]


PerformanceCounter.MilliSeconds Property

The number of milliseconds recorded

[Visual Basic]
Public ReadOnly Property MilliSeconds As Long
[C#]
public long MilliSeconds {get;}

See Also

PerformanceCounter Class | PerformanceCounter Members | SynSoft.Performance Namespace

Copyright © Synesis Software Pty Ltd, 2002-2003

Generated from assembly SynSoft.NET.Perf [1.0.1279.28854]


PerformanceCounter.PeriodCount Property

The elapsed interval (in machine-specific increments)

[Visual Basic]
Public ReadOnly Property PeriodCount As Long
[C#]
public long PeriodCount {get;}

See Also

PerformanceCounter Class | PerformanceCounter Members | SynSoft.Performance Namespace

Copyright © Synesis Software Pty Ltd, 2002-2003

Generated from assembly SynSoft.NET.Perf [1.0.1279.28854]


PerformanceCounter.Seconds Property

The number of seconds recorded

[Visual Basic]
Public ReadOnly Property Seconds As Long
[C#]
public long Seconds {get;}

See Also

PerformanceCounter Class | PerformanceCounter Members | SynSoft.Performance Namespace

Copyright © Synesis Software Pty Ltd, 2002-2003

Generated from assembly SynSoft.NET.Perf [1.0.1279.28854]


PerformanceCounter Methods

The methods of the PerformanceCounter class are listed below. For a complete list of PerformanceCounter class members, see the PerformanceCounter Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Start | Begins the measurement interval
Stop | Ends the measurement interval
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

PerformanceCounter Class | SynSoft.Performance Namespace

Copyright © Synesis Software Pty Ltd, 2002-2003

Generated from assembly SynSoft.NET.Perf [1.0.1279.28854]


PerformanceCounter.Start Method

Begins the measurement interval

[Visual Basic]
Public Sub Start()
[C#]
public void Start();

See Also

PerformanceCounter Class | PerformanceCounter Members | SynSoft.Performance Namespace

Copyright © Synesis Software Pty Ltd, 2002-2003

Generated from assembly SynSoft.NET.Perf [1.0.1279.28854]


PerformanceCounter.Stop Method

Ends the measurement interval

[Visual Basic]
Public Sub Stop()
[C#]
public void Stop();

See Also

PerformanceCounter Class | PerformanceCounter Members | SynSoft.Performance Namespace

Copyright © Synesis Software Pty Ltd, 2002-2003

Generated from assembly SynSoft.NET.Perf [1.0.1279.28854]


ProcessTimesCounter Class

Process-specific performance counter

For a list of all members of this type, see ProcessTimesCounter Members.

System.Object
ProcessTimesCounter

[Visual Basic]
NotInheritable Public Class ProcessTimesCounter
[C#]
public sealed class ProcessTimesCounter

Requirements

Namespace: SynSoft.Performance Namespace

Assembly: SynSoft.NET.Perf.dll

See Also

ProcessTimesCounter Members | SynSoft.Performance Namespace

Copyright © Synesis Software Pty Ltd, 2002-2003

Generated from assembly SynSoft.NET.Perf [1.0.1279.28854]


ProcessTimesCounter Members

Public Instance Constructors

ProcessTimesCounter Constructor Initializes a new instance of the ProcessTimesCounter class.

Public Instance Properties

KernelMicroSeconds | The number of microseconds of kernel time recorded
KernelMilliSeconds | The number of milliseconds of kernel time recorded
KernelPeriodCount | The elapsed interval (in 100ns increments)
KernelSeconds | The number of seconds of kernel time recorded
MicroSeconds | The number of microseconds recorded
MilliSeconds | The number of milliseconds recorded
PeriodCount | The elapsed interval (in 100ns increments)
Seconds | The number of seconds recorded
UserMicroSeconds | The number of microseconds of user time recorded
UserMilliSeconds | The number of milliseconds of user time recorded
UserPeriodCount | The elapsed interval (in 100ns increments)
UserSeconds | The number of seconds of user time recorded

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Start | Begins the measurement interval
Stop | Ends the measurement interval
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ProcessTimesCounter Class | SynSoft.Performance Namespace

Copyright © Synesis Software Pty Ltd, 2002-2003

Generated from assembly SynSoft.NET.Perf [1.0.1279.28854]


ProcessTimesCounter Constructor

Initializes a new instance of the ProcessTimesCounter class.

[Visual Basic]
Public Sub New()
[C#]
public ProcessTimesCounter();

See Also

ProcessTimesCounter Class | ProcessTimesCounter Members | SynSoft.Performance Namespace

Copyright © Synesis Software Pty Ltd, 2002-2003

Generated from assembly SynSoft.NET.Perf [1.0.1279.28854]


ProcessTimesCounter Properties

The properties of the ProcessTimesCounter class are listed below. For a complete list of ProcessTimesCounter class members, see the ProcessTimesCounter Members topic.

Public Instance Properties

KernelMicroSeconds | The number of microseconds of kernel time recorded
KernelMilliSeconds | The number of milliseconds of kernel time recorded
KernelPeriodCount | The elapsed interval (in 100ns increments)
KernelSeconds | The number of seconds of kernel time recorded
MicroSeconds | The number of microseconds recorded
MilliSeconds | The number of milliseconds recorded
PeriodCount | The elapsed interval (in 100ns increments)
Seconds | The number of seconds recorded
UserMicroSeconds | The number of microseconds of user time recorded
UserMilliSeconds | The number of milliseconds of user time recorded
UserPeriodCount | The elapsed interval (in 100ns increments)
UserSeconds | The number of seconds of user time recorded

See Also

ProcessTimesCounter Class | SynSoft.Performance Namespace

Copyright © Synesis Software Pty Ltd, 2002-2003

Generated from assembly SynSoft.NET.Perf [1.0.1279.28854]


ProcessTimesCounter.KernelMicroSeconds Property

The number of microseconds of kernel time recorded

[Visual Basic]
Public ReadOnly Property KernelMicroSeconds As Long
[C#]
public long KernelMicroSeconds {get;}

See Also

ProcessTimesCounter Class | ProcessTimesCounter Members | SynSoft.Performance Namespace

Copyright © Synesis Software Pty Ltd, 2002-2003

Generated from assembly SynSoft.NET.Perf [1.0.1279.28854]


ProcessTimesCounter.KernelMilliSeconds Property

The number of milliseconds of kernel time recorded

[Visual Basic]
Public ReadOnly Property KernelMilliSeconds As Long
[C#]
public long KernelMilliSeconds {get;}

See Also

ProcessTimesCounter Class | ProcessTimesCounter Members | SynSoft.Performance Namespace

Copyright © Synesis Software Pty Ltd, 2002-2003

Generated from assembly SynSoft.NET.Perf [1.0.1279.28854]


ProcessTimesCounter.KernelPeriodCount Property

The elapsed interval (in 100ns increments)

[Visual Basic]
Public ReadOnly Property KernelPeriodCount As Long
[C#]
public long KernelPeriodCount {get;}

See Also

ProcessTimesCounter Class | ProcessTimesCounter Members | SynSoft.Performance Namespace

Copyright © Synesis Software Pty Ltd, 2002-2003

Generated from assembly SynSoft.NET.Perf [1.0.1279.28854]


ProcessTimesCounter.KernelSeconds Property

The number of seconds of kernel time recorded

[Visual Basic]
Public ReadOnly Property KernelSeconds As Long
[C#]
public long KernelSeconds {get;}

See Also

ProcessTimesCounter Class | ProcessTimesCounter Members | SynSoft.Performance Namespace

Copyright © Synesis Software Pty Ltd, 2002-2003

Generated from assembly SynSoft.NET.Perf [1.0.1279.28854]


ProcessTimesCounter.MicroSeconds Property

The number of microseconds recorded

[Visual Basic]
Public ReadOnly Property MicroSeconds As Long
[C#]
public long MicroSeconds {get;}

See Also

ProcessTimesCounter Class | ProcessTimesCounter Members | SynSoft.Performance Namespace

Copyright © Synesis Software Pty Ltd, 2002-2003

Generated from assembly SynSoft.NET.Perf [1.0.1279.28854]


ProcessTimesCounter.MilliSeconds Property

The number of milliseconds recorded

[Visual Basic]
Public ReadOnly Property MilliSeconds As Long
[C#]
public long MilliSeconds {get;}

See Also

ProcessTimesCounter Class | ProcessTimesCounter Members | SynSoft.Performance Namespace

Copyright © Synesis Software Pty Ltd, 2002-2003

Generated from assembly SynSoft.NET.Perf [1.0.1279.28854]


ProcessTimesCounter.PeriodCount Property

The elapsed interval (in 100ns increments)

[Visual Basic]
Public ReadOnly Property PeriodCount As Long
[C#]
public long PeriodCount {get;}

See Also

ProcessTimesCounter Class | ProcessTimesCounter Members | SynSoft.Performance Namespace

Copyright © Synesis Software Pty Ltd, 2002-2003

Generated from assembly SynSoft.NET.Perf [1.0.1279.28854]


ProcessTimesCounter.Seconds Property

The number of seconds recorded

[Visual Basic]
Public ReadOnly Property Seconds As Long
[C#]
public long Seconds {get;}

See Also

ProcessTimesCounter Class | ProcessTimesCounter Members | SynSoft.Performance Namespace

Copyright © Synesis Software Pty Ltd, 2002-2003

Generated from assembly SynSoft.NET.Perf [1.0.1279.28854]


ProcessTimesCounter.UserMicroSeconds Property

The number of microseconds of user time recorded

[Visual Basic]
Public ReadOnly Property UserMicroSeconds As Long
[C#]
public long UserMicroSeconds {get;}

See Also

ProcessTimesCounter Class | ProcessTimesCounter Members | SynSoft.Performance Namespace

Copyright © Synesis Software Pty Ltd, 2002-2003

Generated from assembly SynSoft.NET.Perf [1.0.1279.28854]


ProcessTimesCounter.UserMilliSeconds Property

The number of milliseconds of user time recorded

[Visual Basic]
Public ReadOnly Property UserMilliSeconds As Long
[C#]
public long UserMilliSeconds {get;}

See Also

ProcessTimesCounter Class | ProcessTimesCounter Members | SynSoft.Performance Namespace

Copyright © Synesis Software Pty Ltd, 2002-2003

Generated from assembly SynSoft.NET.Perf [1.0.1279.28854]


ProcessTimesCounter.UserPeriodCount Property

The elapsed interval (in 100ns increments)

[Visual Basic]
Public ReadOnly Property UserPeriodCount As Long
[C#]
public long UserPeriodCount {get;}

See Also

ProcessTimesCounter Class | ProcessTimesCounter Members | SynSoft.Performance Namespace

Copyright © Synesis Software Pty Ltd, 2002-2003

Generated from assembly SynSoft.NET.Perf [1.0.1279.28854]


ProcessTimesCounter.UserSeconds Property

The number of seconds of user time recorded

[Visual Basic]
Public ReadOnly Property UserSeconds As Long
[C#]
public long UserSeconds {get;}

See Also

ProcessTimesCounter Class | ProcessTimesCounter Members | SynSoft.Performance Namespace

Copyright © Synesis Software Pty Ltd, 2002-2003

Generated from assembly SynSoft.NET.Perf [1.0.1279.28854]


ProcessTimesCounter Methods

The methods of the ProcessTimesCounter class are listed below. For a complete list of ProcessTimesCounter class members, see the ProcessTimesCounter Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Start | Begins the measurement interval
Stop | Ends the measurement interval
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ProcessTimesCounter Class | SynSoft.Performance Namespace

Copyright © Synesis Software Pty Ltd, 2002-2003

Generated from assembly SynSoft.NET.Perf [1.0.1279.28854]


ProcessTimesCounter.Start Method

Begins the measurement interval

[Visual Basic]
Public Sub Start()
[C#]
public void Start();

See Also

ProcessTimesCounter Class | ProcessTimesCounter Members | SynSoft.Performance Namespace

Copyright © Synesis Software Pty Ltd, 2002-2003

Generated from assembly SynSoft.NET.Perf [1.0.1279.28854]


ProcessTimesCounter.Stop Method

Ends the measurement interval

[Visual Basic]
Public Sub Stop()
[C#]
public void Stop();

See Also

ProcessTimesCounter Class | ProcessTimesCounter Members | SynSoft.Performance Namespace

Copyright © Synesis Software Pty Ltd, 2002-2003

Generated from assembly SynSoft.NET.Perf [1.0.1279.28854]


ThreadTimesCounter Class

Thread-specific performance counter

For a list of all members of this type, see ThreadTimesCounter Members.

System.Object
ThreadTimesCounter

[Visual Basic]
NotInheritable Public Class ThreadTimesCounter
[C#]
public sealed class ThreadTimesCounter

Requirements

Namespace: SynSoft.Performance Namespace

Assembly: SynSoft.NET.Perf.dll

See Also

ThreadTimesCounter Members | SynSoft.Performance Namespace

Copyright © Synesis Software Pty Ltd, 2002-2003

Generated from assembly SynSoft.NET.Perf [1.0.1279.28854]


ThreadTimesCounter Members

Public Instance Constructors

ThreadTimesCounter Constructor Creates an instance of the ThreadTimesCounter

Public Instance Properties

KernelMicroSeconds | The number of microseconds of kernel time recorded
KernelMilliSeconds | The number of milliseconds of kernel time recorded
KernelPeriodCount | The elapsed interval (in 100ns increments)
KernelSeconds | The number of seconds of kernel time recorded
MicroSeconds | The number of microseconds recorded
MilliSeconds | The number of milliseconds recorded
PeriodCount | The elapsed interval (in 100ns increments)
Seconds | The number of seconds recorded
UserMicroSeconds | The number of microseconds of user time recorded
UserMilliSeconds | The number of milliseconds of user time recorded
UserPeriodCount | The elapsed interval (in 100ns increments)
UserSeconds | The number of seconds of user time recorded

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Start | Begins the measurement interval
Stop | Ends the measurement interval
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ThreadTimesCounter Class | SynSoft.Performance Namespace

Copyright © Synesis Software Pty Ltd, 2002-2003

Generated from assembly SynSoft.NET.Perf [1.0.1279.28854]


ThreadTimesCounter Constructor

Creates an instance of the ThreadTimesCounter

[Visual Basic]
Public Sub New()
[C#]
public ThreadTimesCounter();

See Also

ThreadTimesCounter Class | ThreadTimesCounter Members | SynSoft.Performance Namespace

Copyright © Synesis Software Pty Ltd, 2002-2003

Generated from assembly SynSoft.NET.Perf [1.0.1279.28854]


ThreadTimesCounter Properties

The properties of the ThreadTimesCounter class are listed below. For a complete list of ThreadTimesCounter class members, see the ThreadTimesCounter Members topic.

Public Instance Properties

KernelMicroSeconds | The number of microseconds of kernel time recorded
KernelMilliSeconds | The number of milliseconds of kernel time recorded
KernelPeriodCount | The elapsed interval (in 100ns increments)
KernelSeconds | The number of seconds of kernel time recorded
MicroSeconds | The number of microseconds recorded
MilliSeconds | The number of milliseconds recorded
PeriodCount | The elapsed interval (in 100ns increments)
Seconds | The number of seconds recorded
UserMicroSeconds | The number of microseconds of user time recorded
UserMilliSeconds | The number of milliseconds of user time recorded
UserPeriodCount | The elapsed interval (in 100ns increments)
UserSeconds | The number of seconds of user time recorded

See Also

ThreadTimesCounter Class | SynSoft.Performance Namespace

Copyright © Synesis Software Pty Ltd, 2002-2003

Generated from assembly SynSoft.NET.Perf [1.0.1279.28854]


ThreadTimesCounter.KernelMicroSeconds Property

The number of microseconds of kernel time recorded

[Visual Basic]
Public ReadOnly Property KernelMicroSeconds As Long
[C#]
public long KernelMicroSeconds {get;}

See Also

ThreadTimesCounter Class | ThreadTimesCounter Members | SynSoft.Performance Namespace

Copyright © Synesis Software Pty Ltd, 2002-2003

Generated from assembly SynSoft.NET.Perf [1.0.1279.28854]


ThreadTimesCounter.KernelMilliSeconds Property

The number of milliseconds of kernel time recorded

[Visual Basic]
Public ReadOnly Property KernelMilliSeconds As Long
[C#]
public long KernelMilliSeconds {get;}

See Also

ThreadTimesCounter Class | ThreadTimesCounter Members | SynSoft.Performance Namespace

Copyright © Synesis Software Pty Ltd, 2002-2003

Generated from assembly SynSoft.NET.Perf [1.0.1279.28854]


ThreadTimesCounter.KernelPeriodCount Property

The elapsed interval (in 100ns increments)

[Visual Basic]
Public ReadOnly Property KernelPeriodCount As Long
[C#]
public long KernelPeriodCount {get;}

See Also

ThreadTimesCounter Class | ThreadTimesCounter Members | SynSoft.Performance Namespace

Copyright © Synesis Software Pty Ltd, 2002-2003

Generated from assembly SynSoft.NET.Perf [1.0.1279.28854]


ThreadTimesCounter.KernelSeconds Property

The number of seconds of kernel time recorded

[Visual Basic]
Public ReadOnly Property KernelSeconds As Long
[C#]
public long KernelSeconds {get;}

See Also

ThreadTimesCounter Class | ThreadTimesCounter Members | SynSoft.Performance Namespace

Copyright © Synesis Software Pty Ltd, 2002-2003

Generated from assembly SynSoft.NET.Perf [1.0.1279.28854]


ThreadTimesCounter.MicroSeconds Property

The number of microseconds recorded

[Visual Basic]
Public ReadOnly Property MicroSeconds As Long
[C#]
public long MicroSeconds {get;}

See Also

ThreadTimesCounter Class | ThreadTimesCounter Members | SynSoft.Performance Namespace

Copyright © Synesis Software Pty Ltd, 2002-2003

Generated from assembly SynSoft.NET.Perf [1.0.1279.28854]


ThreadTimesCounter.MilliSeconds Property

The number of milliseconds recorded

[Visual Basic]
Public ReadOnly Property MilliSeconds As Long
[C#]
public long MilliSeconds {get;}

See Also

ThreadTimesCounter Class | ThreadTimesCounter Members | SynSoft.Performance Namespace

Copyright © Synesis Software Pty Ltd, 2002-2003

Generated from assembly SynSoft.NET.Perf [1.0.1279.28854]


ThreadTimesCounter.PeriodCount Property

The elapsed interval (in 100ns increments)

[Visual Basic]
Public ReadOnly Property PeriodCount As Long
[C#]
public long PeriodCount {get;}

See Also

ThreadTimesCounter Class | ThreadTimesCounter Members | SynSoft.Performance Namespace

Copyright © Synesis Software Pty Ltd, 2002-2003

Generated from assembly SynSoft.NET.Perf [1.0.1279.28854]


ThreadTimesCounter.Seconds Property

The number of seconds recorded

[Visual Basic]
Public ReadOnly Property Seconds As Long
[C#]
public long Seconds {get;}

See Also

ThreadTimesCounter Class | ThreadTimesCounter Members | SynSoft.Performance Namespace

Copyright © Synesis Software Pty Ltd, 2002-2003

Generated from assembly SynSoft.NET.Perf [1.0.1279.28854]


ThreadTimesCounter.UserMicroSeconds Property

The number of microseconds of user time recorded

[Visual Basic]
Public ReadOnly Property UserMicroSeconds As Long
[C#]
public long UserMicroSeconds {get;}

See Also

ThreadTimesCounter Class | ThreadTimesCounter Members | SynSoft.Performance Namespace

Copyright © Synesis Software Pty Ltd, 2002-2003

Generated from assembly SynSoft.NET.Perf [1.0.1279.28854]


ThreadTimesCounter.UserMilliSeconds Property

The number of milliseconds of user time recorded

[Visual Basic]
Public ReadOnly Property UserMilliSeconds As Long
[C#]
public long UserMilliSeconds {get;}

See Also

ThreadTimesCounter Class | ThreadTimesCounter Members | SynSoft.Performance Namespace

Copyright © Synesis Software Pty Ltd, 2002-2003

Generated from assembly SynSoft.NET.Perf [1.0.1279.28854]


ThreadTimesCounter.UserPeriodCount Property

The elapsed interval (in 100ns increments)

[Visual Basic]
Public ReadOnly Property UserPeriodCount As Long
[C#]
public long UserPeriodCount {get;}

See Also

ThreadTimesCounter Class | ThreadTimesCounter Members | SynSoft.Performance Namespace

Copyright © Synesis Software Pty Ltd, 2002-2003

Generated from assembly SynSoft.NET.Perf [1.0.1279.28854]


ThreadTimesCounter.UserSeconds Property

The number of seconds of user time recorded

[Visual Basic]
Public ReadOnly Property UserSeconds As Long
[C#]
public long UserSeconds {get;}

See Also

ThreadTimesCounter Class | ThreadTimesCounter Members | SynSoft.Performance Namespace

Copyright © Synesis Software Pty Ltd, 2002-2003

Generated from assembly SynSoft.NET.Perf [1.0.1279.28854]


ThreadTimesCounter Methods

The methods of the ThreadTimesCounter class are listed below. For a complete list of ThreadTimesCounter class members, see the ThreadTimesCounter Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Start | Begins the measurement interval
Stop | Ends the measurement interval
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ThreadTimesCounter Class | SynSoft.Performance Namespace

Copyright © Synesis Software Pty Ltd, 2002-2003

Generated from assembly SynSoft.NET.Perf [1.0.1279.28854]


ThreadTimesCounter.Start Method

Begins the measurement interval

[Visual Basic]
Public Sub Start()
[C#]
public void Start();

See Also

ThreadTimesCounter Class | ThreadTimesCounter Members | SynSoft.Performance Namespace

Copyright © Synesis Software Pty Ltd, 2002-2003

Generated from assembly SynSoft.NET.Perf [1.0.1279.28854]


ThreadTimesCounter.Stop Method

Ends the measurement interval

[Visual Basic]
Public Sub Stop()
[C#]
public void Stop();

See Also

ThreadTimesCounter Class | ThreadTimesCounter Members | SynSoft.Performance Namespace

Copyright © Synesis Software Pty Ltd, 2002-2003

Generated from assembly SynSoft.NET.Perf [1.0.1279.28854]


TickCounter Class

Performance counter based on the system Tick counter

For a list of all members of this type, see TickCounter Members.

System.Object
TickCounter

[Visual Basic]
NotInheritable Public Class TickCounter
[C#]
public sealed class TickCounter

Requirements

Namespace: SynSoft.Performance Namespace

Assembly: SynSoft.NET.Perf.dll

See Also

TickCounter Members | SynSoft.Performance Namespace

Copyright © Synesis Software Pty Ltd, 2002-2003

Generated from assembly SynSoft.NET.Perf [1.0.1279.28854]


TickCounter Members

Public Instance Constructors

TickCounter Constructor Creates an instance of the TickCounter

Public Instance Properties

MicroSeconds | The number of microseconds recorded
MilliSeconds | The number of milliseconds recorded
PeriodCount | The elapsed interval (in ms increments)
Seconds | The number of seconds recorded

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Start | Begins the measurement interval
Stop | Ends the measurement interval
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

TickCounter Class | SynSoft.Performance Namespace

Copyright © Synesis Software Pty Ltd, 2002-2003

Generated from assembly SynSoft.NET.Perf [1.0.1279.28854]


TickCounter Constructor

Creates an instance of the TickCounter

[Visual Basic]
Public Sub New()
[C#]
public TickCounter();

See Also

TickCounter Class | TickCounter Members | SynSoft.Performance Namespace

Copyright © Synesis Software Pty Ltd, 2002-2003

Generated from assembly SynSoft.NET.Perf [1.0.1279.28854]


TickCounter Properties

The properties of the TickCounter class are listed below. For a complete list of TickCounter class members, see the TickCounter Members topic.

Public Instance Properties

MicroSeconds | The number of microseconds recorded
MilliSeconds | The number of milliseconds recorded
PeriodCount | The elapsed interval (in ms increments)
Seconds | The number of seconds recorded

See Also

TickCounter Class | SynSoft.Performance Namespace

Copyright © Synesis Software Pty Ltd, 2002-2003

Generated from assembly SynSoft.NET.Perf [1.0.1279.28854]


TickCounter.MicroSeconds Property

The number of microseconds recorded

[Visual Basic]
Public ReadOnly Property MicroSeconds As Long
[C#]
public long MicroSeconds {get;}

See Also

TickCounter Class | TickCounter Members | SynSoft.Performance Namespace

Copyright © Synesis Software Pty Ltd, 2002-2003

Generated from assembly SynSoft.NET.Perf [1.0.1279.28854]


TickCounter.MilliSeconds Property

The number of milliseconds recorded

[Visual Basic]
Public ReadOnly Property MilliSeconds As Long
[C#]
public long MilliSeconds {get;}

See Also

TickCounter Class | TickCounter Members | SynSoft.Performance Namespace

Copyright © Synesis Software Pty Ltd, 2002-2003

Generated from assembly SynSoft.NET.Perf [1.0.1279.28854]


TickCounter.PeriodCount Property

The elapsed interval (in ms increments)

[Visual Basic]
Public ReadOnly Property PeriodCount As Long
[C#]
public long PeriodCount {get;}

See Also

TickCounter Class | TickCounter Members | SynSoft.Performance Namespace

Copyright © Synesis Software Pty Ltd, 2002-2003

Generated from assembly SynSoft.NET.Perf [1.0.1279.28854]


TickCounter.Seconds Property

The number of seconds recorded

[Visual Basic]
Public ReadOnly Property Seconds As Long
[C#]
public long Seconds {get;}

See Also

TickCounter Class | TickCounter Members | SynSoft.Performance Namespace

Copyright © Synesis Software Pty Ltd, 2002-2003

Generated from assembly SynSoft.NET.Perf [1.0.1279.28854]


TickCounter Methods

The methods of the TickCounter class are listed below. For a complete list of TickCounter class members, see the TickCounter Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Start | Begins the measurement interval
Stop | Ends the measurement interval
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

TickCounter Class | SynSoft.Performance Namespace

Copyright © Synesis Software Pty Ltd, 2002-2003

Generated from assembly SynSoft.NET.Perf [1.0.1279.28854]


TickCounter.Start Method

Begins the measurement interval

[Visual Basic]
Public Sub Start()
[C#]
public void Start();

See Also

TickCounter Class | TickCounter Members | SynSoft.Performance Namespace

Copyright © Synesis Software Pty Ltd, 2002-2003

Generated from assembly SynSoft.NET.Perf [1.0.1279.28854]


TickCounter.Stop Method

Ends the measurement interval

[Visual Basic]
Public Sub Stop()
[C#]
public void Stop();

See Also

TickCounter Class | TickCounter Members | SynSoft.Performance Namespace

Copyright © Synesis Software Pty Ltd, 2002-2003

Generated from assembly SynSoft.NET.Perf [1.0.1279.28854]


SynSoft.Text

SynSoft .NET Libraries (release 3rd July 2003)

SynSoft.Text Namespace

Classes

Class | Description
Tokeniser | This class provides methods for tokenising


Tokeniser Class

This class provides methods for tokenising

For a list of all members of this type, see Tokeniser Members.

System.Object
Tokeniser

[Visual Basic]
NotInheritable Public Class Tokeniser
[C#]
public sealed class Tokeniser

Requirements

Namespace: SynSoft.Text Namespace

Assembly: SynSoft.NET.Text.dll

See Also

Tokeniser Members | SynSoft.Text Namespace

Copyright © Synesis Software Pty Ltd, 2002-2003

Generated from assembly SynSoft.NET.Text [1.0.1279.28863]


Tokeniser Members

Public Static (Shared) Methods

Tokenise Overloaded. Tokenises a string with a string delimiter, returning any blank fields as empty strings

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Tokeniser Class | SynSoft.Text Namespace

Copyright © Synesis Software Pty Ltd, 2002-2003

Generated from assembly SynSoft.NET.Text [1.0.1279.28863]


Tokeniser Methods

The methods of the Tokeniser class are listed below. For a complete list of Tokeniser class members, see the Tokeniser Members topic.

Public Static (Shared) Methods

Tokenise Overloaded. Tokenises a string with a string delimiter, returning any blank fields as empty strings

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Tokeniser Class | SynSoft.Text Namespace

Copyright © Synesis Software Pty Ltd, 2002-2003

Generated from assembly SynSoft.NET.Text [1.0.1279.28863]


Tokenise Method

SynSoft .NET Libraries (release 3rd July 2003)

Tokeniser.Tokenise Method

Tokenises a string with a character delimiter, returning any blank fields as empty strings

Overload List

Tokenises a string with a string delimiter, returning any blank fields as empty strings

public static string[] Tokenise(string,string);

Tokenises a string with a string delimiter, removing or eliding any blank fields according to the given parameter

public static string[] Tokenise(string,string,bool);

Tokenises a string with a character delimiter, returning any blank fields as empty strings

public static string[] Tokenise(string,char);

Tokenises a string with a character delimiter, removing or eliding any blank fields according to the given parameter

public static string[] Tokenise(string,char,bool);

See Also

Tokeniser Class | Tokeniser Members | SynSoft.Text Namespace

Copyright © Synesis Software Pty Ltd, 2002-2003

Generated from assembly SynSoft.NET.Text [1.0.1279.28863]


Tokeniser.Tokenise Method (String, Char)

Tokenises a string with a character delimiter, returning any blank fields as empty strings

[Visual Basic]
Overloads Public Shared Function Tokenise( _
   ByVal s As String, _
   ByVal delim As Char _
) As String()
[C#]
public static string[] Tokenise(
string s,
char delim
);

Parameters

s
The string to tokenise
delim
The delimiter

Return Value

An array of tokens

See Also

Tokeniser Class | Tokeniser Members | SynSoft.Text Namespace | Tokeniser.Tokenise Overload List

Copyright © Synesis Software Pty Ltd, 2002-2003

Generated from assembly SynSoft.NET.Text [1.0.1279.28863]


Tokeniser.Tokenise Method (String, Char, Boolean)

Tokenises a string with a character delimiter, removing or eliding any blank fields according to the given parameter

[Visual Basic]
Overloads Public Shared Function Tokenise( _
   ByVal s As String, _
   ByVal delim As Char, _
   ByVal bElideBlanks As Boolean _
) As String()
[C#]
public static string[] Tokenise(
string s,
char delim,
bool bElideBlanks
);

Parameters

s
The string to tokenise
delim
The delimiter
bElideBlanks
If true blanks are elided, if false they are preserved

Return Value

An array of tokens

See Also

Tokeniser Class | Tokeniser Members | SynSoft.Text Namespace | Tokeniser.Tokenise Overload List

Copyright © Synesis Software Pty Ltd, 2002-2003

Generated from assembly SynSoft.NET.Text [1.0.1279.28863]


Tokeniser.Tokenise Method (String, String)

Tokenises a string with a string delimiter, returning any blank fields as empty strings

[Visual Basic]
Overloads Public Shared Function Tokenise( _
   ByVal s As String, _
   ByVal delim As String _
) As String()
[C#]
public static string[] Tokenise(
string s,
string delim
);

Parameters

s
The string to tokenise
delim
The delimiter

Return Value

An array of tokens

See Also

Tokeniser Class | Tokeniser Members | SynSoft.Text Namespace | Tokeniser.Tokenise Overload List

Copyright © Synesis Software Pty Ltd, 2002-2003

Generated from assembly SynSoft.NET.Text [1.0.1279.28863]


Tokeniser.Tokenise Method (String, String, Boolean)

Tokenises a string with a string delimiter, removing or eliding any blank fields according to the given parameter

[Visual Basic]
Overloads Public Shared Function Tokenise( _
   ByVal s As String, _
   ByVal delim As String, _
   ByVal bElideBlanks As Boolean _
) As String()
[C#]
public static string[] Tokenise(
string s,
string delim,
bool bElideBlanks
);

Parameters

s
The string to tokenise
delim
The delimiter
bElideBlanks
If true blanks are elided, if false they are preserved

Return Value

An array of tokens

See Also

Tokeniser Class | Tokeniser Members | SynSoft.Text Namespace | Tokeniser.Tokenise Overload List

Copyright © Synesis Software Pty Ltd, 2002-2003

Generated from assembly SynSoft.NET.Text [1.0.1279.28863]