Main Page

SynSoft D Libraries Documentation

1.0

Generated on Thu Apr 3 15:41:14 2003 for SynSoft D Libraries by doxygen 1.2.18


File Index

SynSoft D Libraries File List

Here is a list of all files with brief descriptions:
perf.d
token.d


perf.d File Reference

Namespaces

namespace synsoft::win32::perf


token.d File Reference

Namespaces

namespace synsoft::win32::token


Annotated Index

SynSoft D Libraries Compound List

Here are the classes, structs, unions and interfaces with brief descriptions:
perf::HighPerformanceCounter | A performance counter that uses the high performance hardware counter on the host machine
perf::PerformanceCounter | A performance counter that uses the most accurate measurement APIs available on the host machine
perf::PerformanceCounterScope< T > | Performance counter scope class generating template
perf::ProcessTimesCounter | A performance counter that provides process-specific performance timings
perf::Scope | Performance counter scoping class
perf::ThreadTimesCounter | A performance counter that provides thread-specific performance timings
perf::TickCounter | A low-cost, low-resolution performance counter


perf::HighPerformanceCounter Class Reference

List of all members.

Detailed Description

A performance counter that uses the high performance hardware counter on the host machine.

This class provides high-resolution performance monitoring using the host machine's high performance hardware counter. This class does not provide meaningful timing information on operating systems that do not provide a high performance hardware counter.

Public Types

typedef long | interval_type
The interval type.

typedef typedef PerformanceCounterScope<
HighPerformanceCounter
> Scope 		scope_type
The scope type.

Public Methods

void | start ()
Starts measurement.

void | stop ()
Ends measurement.

interval_type get_period_count ()
The elapsed count in the measurement period.

interval_type get_seconds ()
The number of whole seconds in the measurement period.

interval_type get_milliseconds ()
The number of whole milliseconds in the measurement period.

interval_type get_microseconds ()
The number of whole microseconds in the measurement period.

Member Typedef Documentation

typedef long perf::HighPerformanceCounter::interval_type

The interval type.

The type of the interval measurement, a 64-bit signed integer

typedef typedef PerformanceCounterScope<HighPerformanceCounter> Scope perf::HighPerformanceCounter::scope_type

The scope type.

The type with which instances of the counter class can be subject to the RAII protocol in order to scope particular measurement intervals

Member Function Documentation

interval_type perf::HighPerformanceCounter::get_microseconds ( ) [inline]

The number of whole microseconds in the measurement period.

This represents the extent, in whole microseconds, of the measurement period

interval_type perf::HighPerformanceCounter::get_milliseconds ( ) [inline]

The number of whole milliseconds in the measurement period.

This represents the extent, in whole milliseconds, of the measurement period

interval_type perf::HighPerformanceCounter::get_period_count ( ) [inline]

The elapsed count in the measurement period.

This represents the extent, in machine-specific increments, of the measurement period

interval_type perf::HighPerformanceCounter::get_seconds ( ) [inline]

The number of whole seconds in the measurement period.

This represents the extent, in whole seconds, of the measurement period

void perf::HighPerformanceCounter::start ( ) [inline]

Starts measurement.

Begins the measurement period

void perf::HighPerformanceCounter::stop ( ) [inline]

Ends measurement.

Ends the measurement period

The documentation for this class was generated from the following file:
  • perf.d


perf::PerformanceCounter Class Reference

List of all members.

Detailed Description

A performance counter that uses the most accurate measurement APIs available on the host machine.

This class attempts to use the high performance hardware counter as its measurement resource, but failing that it defaults to less accurate resources in order to guarantee that meaningful measurements are always available to application code

Public Types

typedef long | interval_type
The interval type.

typedef typedef PerformanceCounterScope<
PerformanceCounter > Scope 		scope_type
The scope type.

Public Methods

void | start ()
Starts measurement.

void | stop ()
Ends measurement.

interval_type get_period_count ()
The elapsed count in the measurement period.

interval_type get_seconds ()
The number of whole seconds in the measurement period.

interval_type get_milliseconds ()
The number of whole milliseconds in the measurement period.

interval_type get_microseconds ()
The number of whole microseconds in the measurement period.

Member Typedef Documentation

typedef long perf::PerformanceCounter::interval_type

The interval type.

The type of the interval measurement, a 64-bit signed integer

typedef typedef PerformanceCounterScope<PerformanceCounter> Scope perf::PerformanceCounter::scope_type

The scope type.

The type with which instances of the counter class can be subject to the RAII protocol in order to scope particular measurement intervals

Member Function Documentation

interval_type perf::PerformanceCounter::get_microseconds ( ) [inline]

The number of whole microseconds in the measurement period.

This represents the extent, in whole microseconds, of the measurement period

interval_type perf::PerformanceCounter::get_milliseconds ( ) [inline]

The number of whole milliseconds in the measurement period.

This represents the extent, in whole milliseconds, of the measurement period

interval_type perf::PerformanceCounter::get_period_count ( ) [inline]

The elapsed count in the measurement period.

This represents the extent, in machine-specific increments, of the measurement period

interval_type perf::PerformanceCounter::get_seconds ( ) [inline]

The number of whole seconds in the measurement period.

This represents the extent, in whole seconds, of the measurement period

void perf::PerformanceCounter::start ( ) [inline]

Starts measurement.

Begins the measurement period

void perf::PerformanceCounter::stop ( ) [inline]

Ends measurement.

Ends the measurement period

The documentation for this class was generated from the following file:
  • perf.d


perf::PerformanceCounterScope< T > Class Reference

Detailed Description

Performance counter scope class generating template.

This template declares the class Scope which manages a performance counter instance, scoping its measurement interval by virtue of its supporting the RAII protocol.

The documentation for this class was generated from the following file:
  • perf.d


perf::ProcessTimesCounter Class Reference

List of all members.

Detailed Description

A performance counter that provides process-specific performance timings.

This class uses the operating system's performance monitoring facilities to provide timing information pertaining to the calling process only, irrespective of the activities of other processes on the system. This class does not provide meaningful timing information on operating systems that do not provide process-specific monitoring.

Public Types

typedef long | interval_type
The interval type.

typedef typedef PerformanceCounterScope<
ProcessTimesCounter > Scope 		scope_type
The scope type.

Public Methods

void | start ()
Starts measurement.

void | stop ()
Ends measurement.

interval_type get_kernel_period_count ()
The elapsed count in the measurement period for kernel mode activity.

interval_type get_kernel_seconds ()
The number of whole seconds in the measurement period for kernel mode activity.

interval_type get_kernel_milliseconds ()
The number of whole milliseconds in the measurement period for kernel mode activity.

interval_type get_kernel_microseconds ()
The number of whole microseconds in the measurement period for kernel mode activity.

interval_type get_user_period_count ()
The elapsed count in the measurement period for user mode activity.

interval_type get_user_seconds ()
The number of whole seconds in the measurement period for user mode activity.

interval_type get_user_milliseconds ()
The number of whole milliseconds in the measurement period for user mode activity.

interval_type get_user_microseconds ()
The number of whole microseconds in the measurement period for user mode activity.

interval_type get_period_count ()
The elapsed count in the measurement period.

interval_type get_seconds ()
The number of whole seconds in the measurement period.

interval_type get_milliseconds ()
The number of whole milliseconds in the measurement period.

interval_type get_microseconds ()
The number of whole microseconds in the measurement period.

Member Typedef Documentation

typedef long perf::ProcessTimesCounter::interval_type

The interval type.

The type of the interval measurement, a 64-bit signed integer

typedef typedef PerformanceCounterScope<ProcessTimesCounter> Scope perf::ProcessTimesCounter::scope_type

The scope type.

The type with which instances of the counter class can be subject to the RAII protocol in order to scope particular measurement intervals

Member Function Documentation

interval_type perf::ProcessTimesCounter::get_kernel_microseconds ( ) [inline]

The number of whole microseconds in the measurement period for kernel mode activity.

This represents the extent, in whole microseconds, of the measurement period for kernel mode activity

interval_type perf::ProcessTimesCounter::get_kernel_milliseconds ( ) [inline]

The number of whole milliseconds in the measurement period for kernel mode activity.

This represents the extent, in whole milliseconds, of the measurement period for kernel mode activity

interval_type perf::ProcessTimesCounter::get_kernel_period_count ( ) [inline]

The elapsed count in the measurement period for kernel mode activity.

This represents the extent, in machine-specific increments, of the measurement period for kernel mode activity

interval_type perf::ProcessTimesCounter::get_kernel_seconds ( ) [inline]

The number of whole seconds in the measurement period for kernel mode activity.

This represents the extent, in whole seconds, of the measurement period for kernel mode activity

interval_type perf::ProcessTimesCounter::get_microseconds ( ) [inline]

The number of whole microseconds in the measurement period.

This represents the extent, in whole microseconds, of the measurement period

interval_type perf::ProcessTimesCounter::get_milliseconds ( ) [inline]

The number of whole milliseconds in the measurement period.

This represents the extent, in whole milliseconds, of the measurement period

interval_type perf::ProcessTimesCounter::get_period_count ( ) [inline]

The elapsed count in the measurement period.

This represents the extent, in machine-specific increments, of the measurement period

interval_type perf::ProcessTimesCounter::get_seconds ( ) [inline]

The number of whole seconds in the measurement period.

This represents the extent, in whole seconds, of the measurement period

interval_type perf::ProcessTimesCounter::get_user_microseconds ( ) [inline]

The number of whole microseconds in the measurement period for user mode activity.

This represents the extent, in whole microseconds, of the measurement period for user mode activity

interval_type perf::ProcessTimesCounter::get_user_milliseconds ( ) [inline]

The number of whole milliseconds in the measurement period for user mode activity.

This represents the extent, in whole milliseconds, of the measurement period for user mode activity

interval_type perf::ProcessTimesCounter::get_user_period_count ( ) [inline]

The elapsed count in the measurement period for user mode activity.

This represents the extent, in machine-specific increments, of the measurement period for user mode activity

interval_type perf::ProcessTimesCounter::get_user_seconds ( ) [inline]

The number of whole seconds in the measurement period for user mode activity.

This represents the extent, in whole seconds, of the measurement period for user mode activity

void perf::ProcessTimesCounter::start ( ) [inline]

Starts measurement.

Begins the measurement period

void perf::ProcessTimesCounter::stop ( ) [inline]

Ends measurement.

Ends the measurement period

The documentation for this class was generated from the following file:
  • perf.d


perf::Scope Class Reference

List of all members.

Detailed Description

Performance counter scoping class.

This auto class manages a performance counter instance, scoping its measurement interval by virtue of its supporting the RAII protocol

Public Types

typedef T | counter_type
The parameterising performance counter class.

Public Methods

this (counter_type counter)
~this ()
void | stop ()
counter_type get_counter ()
Returns a reference to the managed counter instance.

Member Typedef Documentation

typedef T perf::Scope::counter_type

The parameterising performance counter class.

Constructor & Destructor Documentation

perf::Scope::~this ( ) [inline]

The measurement interval is completed with a call to stop() on the managed counter instance.

Member Function Documentation

counter_type perf::Scope::get_counter ( ) [inline]

Returns a reference to the managed counter instance.

void perf::Scope::stop ( ) [inline]

Calls stop() on the managed counter instance, so that intermediate timings can be taken.

perf::Scope::this ( counter_type counter ) [inline]

Constructs an instance of the PerformanceCounterScope using a reference to the parameterising performance counter class, whose measurement is to be scoped. The measurement interval is commenced with a call to start() on the managed counter instance.

The documentation for this class was generated from the following file:
  • perf.d


perf::ThreadTimesCounter Class Reference

List of all members.

Detailed Description

A performance counter that provides thread-specific performance timings.

This class uses the operating system's performance monitoring facilities to provide timing information pertaining to the calling thread only, irrespective of the activities of other threads on the system. This class does not provide meaningful timing information on operating systems that do not provide thread-specific monitoring.

Public Types

typedef long | interval_type
The interval type.

typedef typedef PerformanceCounterScope<
ThreadTimesCounter > Scope 		scope_type
The scope type.

Public Methods

this ()
Constructor.

void | start ()
Starts measurement.

void | stop ()
Ends measurement.

interval_type get_kernel_period_count ()
The elapsed count in the measurement period for kernel mode activity.

interval_type get_kernel_seconds ()
The number of whole seconds in the measurement period for kernel mode activity.

interval_type get_kernel_milliseconds ()
The number of whole milliseconds in the measurement period for kernel mode activity.

interval_type get_kernel_microseconds ()
The number of whole microseconds in the measurement period for kernel mode activity.

interval_type get_user_period_count ()
The elapsed count in the measurement period for user mode activity.

interval_type get_user_seconds ()
The number of whole seconds in the measurement period for user mode activity.

interval_type get_user_milliseconds ()
The number of whole milliseconds in the measurement period for user mode activity.

interval_type get_user_microseconds ()
The number of whole microseconds in the measurement period for user mode activity.

interval_type get_period_count ()
The elapsed count in the measurement period.

interval_type get_seconds ()
The number of whole seconds in the measurement period.

interval_type get_milliseconds ()
The number of whole milliseconds in the measurement period.

interval_type get_microseconds ()
The number of whole microseconds in the measurement period.

Member Typedef Documentation

typedef long perf::ThreadTimesCounter::interval_type

The interval type.

The type of the interval measurement, a 64-bit signed integer

typedef typedef PerformanceCounterScope<ThreadTimesCounter> Scope perf::ThreadTimesCounter::scope_type

The scope type.

The type with which instances of the counter class can be subject to the RAII protocol in order to scope particular measurement intervals

Member Function Documentation

interval_type perf::ThreadTimesCounter::get_kernel_microseconds ( ) [inline]

The number of whole microseconds in the measurement period for kernel mode activity.

This represents the extent, in whole microseconds, of the measurement period for kernel mode activity

interval_type perf::ThreadTimesCounter::get_kernel_milliseconds ( ) [inline]

The number of whole milliseconds in the measurement period for kernel mode activity.

This represents the extent, in whole milliseconds, of the measurement period for kernel mode activity

interval_type perf::ThreadTimesCounter::get_kernel_period_count ( ) [inline]

The elapsed count in the measurement period for kernel mode activity.

This represents the extent, in machine-specific increments, of the measurement period for kernel mode activity

interval_type perf::ThreadTimesCounter::get_kernel_seconds ( ) [inline]

The number of whole seconds in the measurement period for kernel mode activity.

This represents the extent, in whole seconds, of the measurement period for kernel mode activity

interval_type perf::ThreadTimesCounter::get_microseconds ( ) [inline]

The number of whole microseconds in the measurement period.

This represents the extent, in whole microseconds, of the measurement period

interval_type perf::ThreadTimesCounter::get_milliseconds ( ) [inline]

The number of whole milliseconds in the measurement period.

This represents the extent, in whole milliseconds, of the measurement period

interval_type perf::ThreadTimesCounter::get_period_count ( ) [inline]

The elapsed count in the measurement period.

This represents the extent, in machine-specific increments, of the measurement period

interval_type perf::ThreadTimesCounter::get_seconds ( ) [inline]

The number of whole seconds in the measurement period.

This represents the extent, in whole seconds, of the measurement period

interval_type perf::ThreadTimesCounter::get_user_microseconds ( ) [inline]

The number of whole microseconds in the measurement period for user mode activity.

This represents the extent, in whole microseconds, of the measurement period for user mode activity

interval_type perf::ThreadTimesCounter::get_user_milliseconds ( ) [inline]

The number of whole milliseconds in the measurement period for user mode activity.

This represents the extent, in whole milliseconds, of the measurement period for user mode activity

interval_type perf::ThreadTimesCounter::get_user_period_count ( ) [inline]

The elapsed count in the measurement period for user mode activity.

This represents the extent, in machine-specific increments, of the measurement period for user mode activity

interval_type perf::ThreadTimesCounter::get_user_seconds ( ) [inline]

The number of whole seconds in the measurement period for user mode activity.

This represents the extent, in whole seconds, of the measurement period for user mode activity

void perf::ThreadTimesCounter::start ( ) [inline]

Starts measurement.

Begins the measurement period

void perf::ThreadTimesCounter::stop ( ) [inline]

Ends measurement.

Ends the measurement period

perf::ThreadTimesCounter::this ( ) [inline]

Constructor.

Creates an instance of the class, and caches the thread token so that measurements will be taken with respect to the thread in which the class was created.

The documentation for this class was generated from the following file:
  • perf.d


perf::TickCounter Class Reference

List of all members.

Detailed Description

A low-cost, low-resolution performance counter.

This class provides low-resolution, but low-latency, performance monitoring and is guaranteed to be meaningful on all operating systems.

Public Types

typedef long | interval_type
The interval type.

typedef typedef PerformanceCounterScope<
TickCounter > Scope 		scope_type
The scope type.

Public Methods

void | start ()
Starts measurement.

void | stop ()
Ends measurement.

interval_type get_period_count ()
The elapsed count in the measurement period.

interval_type get_seconds ()
The number of whole seconds in the measurement period.

interval_type get_milliseconds ()
The number of whole milliseconds in the measurement period.

interval_type get_microseconds ()
The number of whole microseconds in the measurement period.

Member Typedef Documentation

typedef long perf::TickCounter::interval_type

The interval type.

The type of the interval measurement, a 64-bit signed integer

typedef typedef PerformanceCounterScope<TickCounter> Scope perf::TickCounter::scope_type

The scope type.

The type with which instances of the counter class can be subject to the RAII protocol in order to scope particular measurement intervals

Member Function Documentation

interval_type perf::TickCounter::get_microseconds ( ) [inline]

The number of whole microseconds in the measurement period.

This represents the extent, in whole microseconds, of the measurement period

interval_type perf::TickCounter::get_milliseconds ( ) [inline]

The number of whole milliseconds in the measurement period.

This represents the extent, in whole milliseconds, of the measurement period

interval_type perf::TickCounter::get_period_count ( ) [inline]

The elapsed count in the measurement period.

This represents the extent, in machine-specific increments, of the measurement period

interval_type perf::TickCounter::get_seconds ( ) [inline]

The number of whole seconds in the measurement period.

This represents the extent, in whole seconds, of the measurement period

void perf::TickCounter::start ( ) [inline]

Starts measurement.

Begins the measurement period

void perf::TickCounter::stop ( ) [inline]

Ends measurement.

Ends the measurement period

The documentation for this class was generated from the following file:
  • perf.d


Compound Member Index

SynSoft D Libraries Compound Members

Here is a list of all class members with links to the class documentation for each member:
  • counter_type : perf::Scope
  • get_counter() : perf::Scope
  • get_kernel_microseconds() : perf::ProcessTimesCounter, perf::ThreadTimesCounter
  • get_kernel_milliseconds() : perf::ProcessTimesCounter, perf::ThreadTimesCounter
  • get_kernel_period_count() : perf::ProcessTimesCounter, perf::ThreadTimesCounter
  • get_kernel_seconds() : perf::ProcessTimesCounter, perf::ThreadTimesCounter
  • get_microseconds() : perf::PerformanceCounter, perf::ProcessTimesCounter, perf::ThreadTimesCounter, perf::TickCounter, perf::HighPerformanceCounter
  • get_milliseconds() : perf::PerformanceCounter, perf::ProcessTimesCounter, perf::ThreadTimesCounter, perf::TickCounter, perf::HighPerformanceCounter
  • get_period_count() : perf::PerformanceCounter, perf::ProcessTimesCounter, perf::ThreadTimesCounter, perf::TickCounter, perf::HighPerformanceCounter
  • get_seconds() : perf::PerformanceCounter, perf::ProcessTimesCounter, perf::ThreadTimesCounter, perf::TickCounter, perf::HighPerformanceCounter
  • get_user_microseconds() : perf::ProcessTimesCounter, perf::ThreadTimesCounter
  • get_user_milliseconds() : perf::ProcessTimesCounter, perf::ThreadTimesCounter
  • get_user_period_count() : perf::ProcessTimesCounter, perf::ThreadTimesCounter
  • get_user_seconds() : perf::ProcessTimesCounter, perf::ThreadTimesCounter
  • interval_type : perf::PerformanceCounter, perf::ProcessTimesCounter, perf::ThreadTimesCounter, perf::TickCounter, perf::HighPerformanceCounter
  • scope_type : perf::PerformanceCounter, perf::ProcessTimesCounter, perf::ThreadTimesCounter, perf::TickCounter, perf::HighPerformanceCounter
  • start() : perf::PerformanceCounter, perf::ProcessTimesCounter, perf::ThreadTimesCounter, perf::TickCounter, perf::HighPerformanceCounter
  • stop() : perf::PerformanceCounter, perf::ProcessTimesCounter, perf::ThreadTimesCounter, perf::TickCounter, perf::HighPerformanceCounter, perf::Scope
  • this() : perf::ThreadTimesCounter, perf::Scope
  • ~this() : perf::Scope


Namespace Index

SynSoft D Libraries Namespace List

Here is a list of all namespaces with brief descriptions:
synsoft::win32::perf
synsoft::win32::token


synsoft::win32::perf Namespace Reference

Compounds

class | HighPerformanceCounter
A performance counter that uses the high performance hardware counter on the host machine. More...

class | PerformanceCounter
A performance counter that uses the most accurate measurement APIs available on the host machine. More...

class | PerformanceCounterScope< T >
Performance counter scope class generating template. More...

class | ProcessTimesCounter
A performance counter that provides process-specific performance timings. More...

class | Scope
Performance counter scoping class. More...

class | ThreadTimesCounter
A performance counter that provides thread-specific performance timings. More...

class | TickCounter
A low-cost, low-resolution performance counter. More...


synsoft::win32::token Namespace Reference

Functions

char[][] | tokenise (char[] source, char delimiter, bit bElideBlanks, bit bZeroTerminate)
Tokenises a string with a character, optionally eliding blanks and/or zero terminating the tokens.

char[][] | tokenize (char[] source, char delimiter, bit bElideBlanks, bit bZeroTerminate)
Tokenizes a string with a character, optionally eliding blanks and/or zero terminating the tokens.

char[][] | tokenise (char[] source, char[] delimiter, bit bElideBlanks, bit bZeroTerminate)
Tokenises a string with a string, optionally eliding blanks and/or zero terminating the tokens.

char[][] | tokenize (char[] source, char[] delimiter, bit bElideBlanks, bit bZeroTerminate)
Tokenizes a string with a string, optionally eliding blanks and/or zero terminating the tokens.

Function Documentation

char [][] tokenise | ( | char | source[],
 |  | char | delimiter[],
 |  | bit | bElideBlanks,
 |  | bit | bZeroTerminate
 | ) |

Tokenises a string with a string, optionally eliding blanks and/or zero terminating the tokens.

Tokenises a string with a character, optionally eliding blanks and/or zero terminating the tokens

Parameters:
source | The string to tokenise
delimiter | The string delimiter with which source is tokenised
bElideBlanks | If true any blank tokens are elided from the results; if false they are preserved
bZeroTerminate | If true the token slices are zero terminated for compatibility with C zero-terminated string functions

char [][] tokenise | ( | char | source[],
 |  | char | delimiter,
 |  | bit | bElideBlanks,
 |  | bit | bZeroTerminate
 | ) |

Tokenises a string with a character, optionally eliding blanks and/or zero terminating the tokens.

Tokenises a string with a character, optionally eliding blanks and/or zero terminating the tokens

Parameters:
source | The string to tokenise
delimiter | The character delimiter with which source is tokenised
bElideBlanks | If true any blank tokens are elided from the results; if false they are preserved
bZeroTerminate | If true the token slices are zero terminated for compatibility with C zero-terminated string functions

char [][] tokenize | ( | char | source[],
 |  | char | delimiter[],
 |  | bit | bElideBlanks,
 |  | bit | bZeroTerminate
 | ) |

Tokenizes a string with a string, optionally eliding blanks and/or zero terminating the tokens.

Tokenizes a string with a character, optionally eliding blanks and/or zero terminating the tokens

Parameters:
source | The string to tokenize
delimiter | The string delimiter with which source is tokenized
bElideBlanks | If true any blank tokens are elided from the results; if false they are preserved
bZeroTerminate | If true the token slices are zero terminated for compatibility with C zero-terminated string functions

char [][] tokenize | ( | char | source[],
 |  | char | delimiter,
 |  | bit | bElideBlanks,
 |  | bit | bZeroTerminate
 | ) |

Tokenizes a string with a character, optionally eliding blanks and/or zero terminating the tokens.

Tokenizes a string with a character, optionally eliding blanks and/or zero terminating the tokens

Parameters:
source | The string to tokenize
delimiter | The character delimiter with which source is tokenized
bElideBlanks | If true any blank tokens are elided from the results; if false they are preserved
bZeroTerminate | If true the token slices are zero terminated for compatibility with C zero-terminated string functions


Namespace Member Index

SynSoft D Libraries Namespace Members

Here is a list of all namespace members with links to the namespace documentation for each member:
  • tokenise() : synsoft::win32::token
  • tokenize() : synsoft::win32::token


Member List

perf::HighPerformanceCounter Member List

This is the complete list of members for perf::HighPerformanceCounter, including all inherited members.
get_microseconds() | perf::HighPerformanceCounter | [inline]
get_milliseconds() | perf::HighPerformanceCounter | [inline]
get_period_count() | perf::HighPerformanceCounter | [inline]
get_seconds() | perf::HighPerformanceCounter | [inline]
interval_type typedef | perf::HighPerformanceCounter |
scope_type typedef | perf::HighPerformanceCounter |
start() | perf::HighPerformanceCounter | [inline]
stop() | perf::HighPerformanceCounter | [inline]


Member List

perf::PerformanceCounter Member List

This is the complete list of members for perf::PerformanceCounter, including all inherited members.
get_microseconds() | perf::PerformanceCounter | [inline]
get_milliseconds() | perf::PerformanceCounter | [inline]
get_period_count() | perf::PerformanceCounter | [inline]
get_seconds() | perf::PerformanceCounter | [inline]
interval_type typedef | perf::PerformanceCounter |
scope_type typedef | perf::PerformanceCounter |
start() | perf::PerformanceCounter | [inline]
stop() | perf::PerformanceCounter | [inline]


Member List

perf::Scope Member List

This is the complete list of members for perf::Scope, including all inherited members.
counter_type typedef | perf::Scope |
get_counter() | perf::Scope | [inline]
stop() | perf::Scope | [inline]
this(counter_type counter) | perf::Scope | [inline]
~this() | perf::Scope | [inline]


Member List

perf::ProcessTimesCounter Member List

This is the complete list of members for perf::ProcessTimesCounter, including all inherited members.
get_kernel_microseconds() | perf::ProcessTimesCounter | [inline]
get_kernel_milliseconds() | perf::ProcessTimesCounter | [inline]
get_kernel_period_count() | perf::ProcessTimesCounter | [inline]
get_kernel_seconds() | perf::ProcessTimesCounter | [inline]
get_microseconds() | perf::ProcessTimesCounter | [inline]
get_milliseconds() | perf::ProcessTimesCounter | [inline]
get_period_count() | perf::ProcessTimesCounter | [inline]
get_seconds() | perf::ProcessTimesCounter | [inline]
get_user_microseconds() | perf::ProcessTimesCounter | [inline]
get_user_milliseconds() | perf::ProcessTimesCounter | [inline]
get_user_period_count() | perf::ProcessTimesCounter | [inline]
get_user_seconds() | perf::ProcessTimesCounter | [inline]
interval_type typedef | perf::ProcessTimesCounter |
scope_type typedef | perf::ProcessTimesCounter |
start() | perf::ProcessTimesCounter | [inline]
stop() | perf::ProcessTimesCounter | [inline]


Member List

perf::ThreadTimesCounter Member List

This is the complete list of members for perf::ThreadTimesCounter, including all inherited members.
get_kernel_microseconds() | perf::ThreadTimesCounter | [inline]
get_kernel_milliseconds() | perf::ThreadTimesCounter | [inline]
get_kernel_period_count() | perf::ThreadTimesCounter | [inline]
get_kernel_seconds() | perf::ThreadTimesCounter | [inline]
get_microseconds() | perf::ThreadTimesCounter | [inline]
get_milliseconds() | perf::ThreadTimesCounter | [inline]
get_period_count() | perf::ThreadTimesCounter | [inline]
get_seconds() | perf::ThreadTimesCounter | [inline]
get_user_microseconds() | perf::ThreadTimesCounter | [inline]
get_user_milliseconds() | perf::ThreadTimesCounter | [inline]
get_user_period_count() | perf::ThreadTimesCounter | [inline]
get_user_seconds() | perf::ThreadTimesCounter | [inline]
interval_type typedef | perf::ThreadTimesCounter |
scope_type typedef | perf::ThreadTimesCounter |
start() | perf::ThreadTimesCounter | [inline]
stop() | perf::ThreadTimesCounter | [inline]
this() | perf::ThreadTimesCounter | [inline]


Member List

perf::TickCounter Member List

This is the complete list of members for perf::TickCounter, including all inherited members.
get_microseconds() | perf::TickCounter | [inline]
get_milliseconds() | perf::TickCounter | [inline]
get_period_count() | perf::TickCounter | [inline]
get_seconds() | perf::TickCounter | [inline]
interval_type typedef | perf::TickCounter |
scope_type typedef | perf::TickCounter |
start() | perf::TickCounter | [inline]
stop() | perf::TickCounter | [inline]