Main Page

SynSoft D Libraries Documentation

1.1
D Libraries documentation © Synesis Software Pty Ltd, 2002-2003


File Index

SynSoft D Libraries File List

Here is a list of all documented files with brief descriptions:
perf.d | This file contains Win32 performance classes
synch.d | This file contains Win32 synchronisation classes
token.d | This file contains string tokenisation classes and functions


perf.d File Reference

Detailed Description

This file contains Win32 performance classes.

Namespaces

namespace synsoft::win32::perf


synch.d File Reference

Detailed Description

This file contains Win32 synchronisation classes.

Namespaces

namespace synsoft::win32::synch


token.d File Reference

Detailed Description

This file contains string tokenisation classes and functions.

Namespaces

namespace synsoft::win32::token


Annotated Index

SynSoft D Libraries Compound List

Here are the classes, structs, unions and interfaces with brief descriptions:
HighPerformanceCounter | A performance counter that uses the high performance hardware counter on the host machine
PerformanceCounter | A performance counter that uses the most accurate measurement APIs available on the host machine
PerformanceCounterScope< T > | Performance counter scope class generating template
ProcessTimesCounter | A performance counter that provides process-specific performance timings
Scope | Performance counter scoping class
Semaphore | This class represents a Win32 semaphore synchronisation object
SynchException | This class is thrown by synchronisation classes in response to serious failures
ThreadTimesCounter | A performance counter that provides thread-specific performance timings
TickCounter | A low-cost, low-resolution performance counter


HighPerformanceCounter Class Reference

List of all members.

Detailed Description

A performance counter that uses the high performance hardware counter on the host machine.

This class provides high-resolution performance monitoring using the host machine's high performance hardware counter. This class does not provide meaningful timing information on operating systems that do not provide a high performance hardware counter.

Public Types

typedef long | interval_type
The interval type.

typedef typedef PerformanceCounterScope<
HighPerformanceCounter
> Scope 		scope_type
The scope type.

Public Methods

void | start ()
Starts measurement.

void | stop ()
Ends measurement.

interval_type get_period_count ()
The elapsed count in the measurement period.

interval_type get_seconds ()
The number of whole seconds in the measurement period.

interval_type get_milliseconds ()
The number of whole milliseconds in the measurement period.

interval_type get_microseconds ()
The number of whole microseconds in the measurement period.

Member Typedef Documentation

typedef long interval_type

The interval type.

The type of the interval measurement, a 64-bit signed integer

typedef typedef PerformanceCounterScope<HighPerformanceCounter> Scope scope_type

The scope type.

The type with which instances of the counter class can be subject to the RAII protocol in order to scope particular measurement intervals

Member Function Documentation

interval_type get_microseconds ( ) [inline]

The number of whole microseconds in the measurement period.

This represents the extent, in whole microseconds, of the measurement period

interval_type get_milliseconds ( ) [inline]

The number of whole milliseconds in the measurement period.

This represents the extent, in whole milliseconds, of the measurement period

interval_type get_period_count ( ) [inline]

The elapsed count in the measurement period.

This represents the extent, in machine-specific increments, of the measurement period

interval_type get_seconds ( ) [inline]

The number of whole seconds in the measurement period.

This represents the extent, in whole seconds, of the measurement period

void start ( ) [inline]

Starts measurement.

Begins the measurement period

void stop ( ) [inline]

Ends measurement.

Ends the measurement period

The documentation for this class was generated from the following file:
  • perf.d


PerformanceCounter Class Reference

List of all members.

Detailed Description

A performance counter that uses the most accurate measurement APIs available on the host machine.

This class attempts to use the high performance hardware counter as its measurement resource, but failing that it defaults to less accurate resources in order to guarantee that meaningful measurements are always available to application code

Public Types

typedef long | interval_type
The interval type.

typedef typedef PerformanceCounterScope<
PerformanceCounter > Scope 		scope_type
The scope type.

Public Methods

void | start ()
Starts measurement.

void | stop ()
Ends measurement.

interval_type get_period_count ()
The elapsed count in the measurement period.

interval_type get_seconds ()
The number of whole seconds in the measurement period.

interval_type get_milliseconds ()
The number of whole milliseconds in the measurement period.

interval_type get_microseconds ()
The number of whole microseconds in the measurement period.

Member Typedef Documentation

typedef long interval_type

The interval type.

The type of the interval measurement, a 64-bit signed integer

typedef typedef PerformanceCounterScope<PerformanceCounter> Scope scope_type

The scope type.

The type with which instances of the counter class can be subject to the RAII protocol in order to scope particular measurement intervals

Member Function Documentation

interval_type get_microseconds ( ) [inline]

The number of whole microseconds in the measurement period.

This represents the extent, in whole microseconds, of the measurement period

interval_type get_milliseconds ( ) [inline]

The number of whole milliseconds in the measurement period.

This represents the extent, in whole milliseconds, of the measurement period

interval_type get_period_count ( ) [inline]

The elapsed count in the measurement period.

This represents the extent, in machine-specific increments, of the measurement period

interval_type get_seconds ( ) [inline]

The number of whole seconds in the measurement period.

This represents the extent, in whole seconds, of the measurement period

void start ( ) [inline]

Starts measurement.

Begins the measurement period

void stop ( ) [inline]

Ends measurement.

Ends the measurement period

The documentation for this class was generated from the following file:
  • perf.d


PerformanceCounterScope< T > Class Reference

Detailed Description

Performance counter scope class generating template.

This template declares the class Scope which manages a performance counter instance, scoping its measurement interval by virtue of its supporting the RAII protocol.

The documentation for this class was generated from the following file:
  • perf.d


ProcessTimesCounter Class Reference

List of all members.

Detailed Description

A performance counter that provides process-specific performance timings.

This class uses the operating system's performance monitoring facilities to provide timing information pertaining to the calling process only, irrespective of the activities of other processes on the system. This class does not provide meaningful timing information on operating systems that do not provide process-specific monitoring.

Public Types

typedef long | interval_type
The interval type.

typedef typedef PerformanceCounterScope<
ProcessTimesCounter > Scope 		scope_type
The scope type.

Public Methods

void | start ()
Starts measurement.

void | stop ()
Ends measurement.

interval_type get_kernel_period_count ()
The elapsed count in the measurement period for kernel mode activity.

interval_type get_kernel_seconds ()
The number of whole seconds in the measurement period for kernel mode activity.

interval_type get_kernel_milliseconds ()
The number of whole milliseconds in the measurement period for kernel mode activity.

interval_type get_kernel_microseconds ()
The number of whole microseconds in the measurement period for kernel mode activity.

interval_type get_user_period_count ()
The elapsed count in the measurement period for user mode activity.

interval_type get_user_seconds ()
The number of whole seconds in the measurement period for user mode activity.

interval_type get_user_milliseconds ()
The number of whole milliseconds in the measurement period for user mode activity.

interval_type get_user_microseconds ()
The number of whole microseconds in the measurement period for user mode activity.

interval_type get_period_count ()
The elapsed count in the measurement period.

interval_type get_seconds ()
The number of whole seconds in the measurement period.

interval_type get_milliseconds ()
The number of whole milliseconds in the measurement period.

interval_type get_microseconds ()
The number of whole microseconds in the measurement period.

Member Typedef Documentation

typedef long interval_type

The interval type.

The type of the interval measurement, a 64-bit signed integer

typedef typedef PerformanceCounterScope<ProcessTimesCounter> Scope scope_type

The scope type.

The type with which instances of the counter class can be subject to the RAII protocol in order to scope particular measurement intervals

Member Function Documentation

interval_type get_kernel_microseconds ( ) [inline]

The number of whole microseconds in the measurement period for kernel mode activity.

This represents the extent, in whole microseconds, of the measurement period for kernel mode activity

interval_type get_kernel_milliseconds ( ) [inline]

The number of whole milliseconds in the measurement period for kernel mode activity.

This represents the extent, in whole milliseconds, of the measurement period for kernel mode activity

interval_type get_kernel_period_count ( ) [inline]

The elapsed count in the measurement period for kernel mode activity.

This represents the extent, in machine-specific increments, of the measurement period for kernel mode activity

interval_type get_kernel_seconds ( ) [inline]

The number of whole seconds in the measurement period for kernel mode activity.

This represents the extent, in whole seconds, of the measurement period for kernel mode activity

interval_type get_microseconds ( ) [inline]

The number of whole microseconds in the measurement period.

This represents the extent, in whole microseconds, of the measurement period

interval_type get_milliseconds ( ) [inline]

The number of whole milliseconds in the measurement period.

This represents the extent, in whole milliseconds, of the measurement period

interval_type get_period_count ( ) [inline]

The elapsed count in the measurement period.

This represents the extent, in machine-specific increments, of the measurement period

interval_type get_seconds ( ) [inline]

The number of whole seconds in the measurement period.

This represents the extent, in whole seconds, of the measurement period

interval_type get_user_microseconds ( ) [inline]

The number of whole microseconds in the measurement period for user mode activity.

This represents the extent, in whole microseconds, of the measurement period for user mode activity

interval_type get_user_milliseconds ( ) [inline]

The number of whole milliseconds in the measurement period for user mode activity.

This represents the extent, in whole milliseconds, of the measurement period for user mode activity

interval_type get_user_period_count ( ) [inline]

The elapsed count in the measurement period for user mode activity.

This represents the extent, in machine-specific increments, of the measurement period for user mode activity

interval_type get_user_seconds ( ) [inline]

The number of whole seconds in the measurement period for user mode activity.

This represents the extent, in whole seconds, of the measurement period for user mode activity

void start ( ) [inline]

Starts measurement.

Begins the measurement period

void stop ( ) [inline]

Ends measurement.

Ends the measurement period

The documentation for this class was generated from the following file:
  • perf.d


Scope Class Reference

List of all members.

Detailed Description

Performance counter scoping class.

This auto class manages a performance counter instance, scoping its measurement interval by virtue of its supporting the RAII protocol

Public Types

typedef T | counter_type
The parameterising performance counter class.

Public Methods

this (counter_type counter)
Constructs an instance of the PerformanceCounterScope using a reference to the parameterising performance counter class, whose measurement is to be scoped.

~this ()
The measurement interval is completed with a call to stop() on the managed counter instance.

void | stop ()
Calls stop() on the managed counter instance, so that intermediate timings can be taken.

counter_type get_counter ()
Returns a reference to the managed counter instance.

Member Typedef Documentation

typedef T counter_type

The parameterising performance counter class.

Constructor & Destructor Documentation

~this ( ) [inline]

The measurement interval is completed with a call to stop() on the managed counter instance.

Member Function Documentation

counter_type get_counter ( ) [inline]

Returns a reference to the managed counter instance.

void stop ( ) [inline]

Calls stop() on the managed counter instance, so that intermediate timings can be taken.

this ( counter_type counter ) [inline]

Constructs an instance of the PerformanceCounterScope using a reference to the parameterising performance counter class, whose measurement is to be scoped.

The measurement interval is commenced with a call to start() on the managed counter instance.

The documentation for this class was generated from the following file:
  • perf.d


Semaphore Class Reference

List of all members.

Detailed Description

This class represents a Win32 semaphore synchronisation object.

Public Methods

Construction
this (int maxSlots)
Creates an anonymous semaphore with the indicated number of slots. All slots are available.

this (int maxSlots, int availableSlots)
Creates an anonymous semaphore with the indicated number of slots.

this (char[] name, int maxSlots)
Creates a named semaphore with the indicated number of slots. All slots are available.

this (char[] name, int maxSlots, int availableSlots)
Creates a named semaphore with the indicated number of slots.

~this ()
Calls the close() method, ensuring that the semaphore is released to the operating system when the object is destroyed.

Methods
void | close ()
Closes the semaphore object handle.

bit | wait (uint timeout)
Waits, for the specified period, for a slot on the semaphore to become available.

void | wait ()
Waits forever for a slot on the semaphore to become available.

void | release (uint cSlots)
Releases the given number of slots acquired on the semaphore.

void | release ()
Releases one slot acquired on the semaphore.

Properties
int | get_num_slots ()
The maximum number of slots in the semaphore.

int | get_available_slots ()
The number of available slots in the semaphore.

char[] | get_name ()
The name of the semaphore.

Public Attributes

Constants
uint | INFINITE = (uint)0xFFFFFFFF
Represents an infinite wait period.

Constructor & Destructor Documentation

~this ( ) [inline]

Calls the close() method, ensuring that the semaphore is released to the operating system when the object is destroyed.

Member Function Documentation

void close ( ) [inline]

Closes the semaphore object handle.

int get_available_slots ( ) [inline]

The number of available slots in the semaphore.

char [] get_name ( ) [inline]

The name of the semaphore.

int get_num_slots ( ) [inline]

The maximum number of slots in the semaphore.

void release ( ) [inline]

Releases one slot acquired on the semaphore.

Note:
A SynchException object is thrown if the release fails

void release ( uint cSlots ) [inline]

Releases the given number of slots acquired on the semaphore.

Parameters:
cSlots The number of slots to release
Note:
A SynchException object is thrown if the release fails

this | ( | char | name[],
 |  | int | maxSlots,
 |  | int | availableSlots
 | ) | [inline]

Creates a named semaphore with the indicated number of slots.

Parameters:
name | The name of the semaphore
maxSlots | The maximum number of slots
availableSlots | The number of slots initially available
Note:
If the semaphore cannot be created the method throws a SynchException object

this | ( | char | name[],
 |  | int | maxSlots
 | ) | [inline]

Creates a named semaphore with the indicated number of slots. All slots are available.

Parameters:
name | The name of the semaphore
maxSlots | The maximum number of slots

this | ( | int | maxSlots,
 |  | int | availableSlots
 | ) | [inline]

Creates an anonymous semaphore with the indicated number of slots.

Parameters:
maxSlots | The maximum number of slots
availableSlots | The number of slots initially available

this ( int maxSlots ) [inline]

Creates an anonymous semaphore with the indicated number of slots. All slots are available.

Parameters:
maxSlots The maximum number of slots

void wait ( ) [inline]

Waits forever for a slot on the semaphore to become available.

Note:
If the wait fails the method throws a SynchException object

bit wait ( uint timeout ) [inline]

Waits, for the specified period, for a slot on the semaphore to become available.

Parameters:
timeout The number of milliseconds to wait, or
Returns:
true if the semaphore slot was aquired, or false if the timeout period elapsed
Note:
If the wait fails the method throws a SynchException object

Member Data Documentation

uint INFINITE = (uint)0xFFFFFFFF

Represents an infinite wait period.

The documentation for this class was generated from the following file:
  • synch.d


SynchException Class Reference

List of all members.

Detailed Description

This class is thrown by synchronisation classes in response to serious failures.

Public Methods

Construction
this (char[] message)
Creates an instance of the exception.

this (char[] message, int error)
Creates an instance of the exception, with the given.

Attributes
int error ()
Returns the Win32 error code associated with the failure.

Member Function Documentation

int error ( ) [inline]

Returns the Win32 error code associated with the failure.

this | ( | char | message[],
 |  | int | error
 | ) | [inline]

Creates an instance of the exception, with the given.

Parameters:
The | message associated with the exception
The | Win32 error number associated with the exception

this ( char message[] ) [inline]

Creates an instance of the exception.

Parameters:
The message associated with the exception

The documentation for this class was generated from the following file:
  • synch.d


ThreadTimesCounter Class Reference

List of all members.

Detailed Description

A performance counter that provides thread-specific performance timings.

This class uses the operating system's performance monitoring facilities to provide timing information pertaining to the calling thread only, irrespective of the activities of other threads on the system. This class does not provide meaningful timing information on operating systems that do not provide thread-specific monitoring.

Public Types

typedef long | interval_type
The interval type.

typedef typedef PerformanceCounterScope<
ThreadTimesCounter > Scope 		scope_type
The scope type.

Public Methods

this ()
Constructor.

void | start ()
Starts measurement.

void | stop ()
Ends measurement.

interval_type get_kernel_period_count ()
The elapsed count in the measurement period for kernel mode activity.

interval_type get_kernel_seconds ()
The number of whole seconds in the measurement period for kernel mode activity.

interval_type get_kernel_milliseconds ()
The number of whole milliseconds in the measurement period for kernel mode activity.

interval_type get_kernel_microseconds ()
The number of whole microseconds in the measurement period for kernel mode activity.

interval_type get_user_period_count ()
The elapsed count in the measurement period for user mode activity.

interval_type get_user_seconds ()
The number of whole seconds in the measurement period for user mode activity.

interval_type get_user_milliseconds ()
The number of whole milliseconds in the measurement period for user mode activity.

interval_type get_user_microseconds ()
The number of whole microseconds in the measurement period for user mode activity.

interval_type get_period_count ()
The elapsed count in the measurement period.

interval_type get_seconds ()
The number of whole seconds in the measurement period.

interval_type get_milliseconds ()
The number of whole milliseconds in the measurement period.

interval_type get_microseconds ()
The number of whole microseconds in the measurement period.

Member Typedef Documentation

typedef long interval_type

The interval type.

The type of the interval measurement, a 64-bit signed integer

typedef typedef PerformanceCounterScope<ThreadTimesCounter> Scope scope_type

The scope type.

The type with which instances of the counter class can be subject to the RAII protocol in order to scope particular measurement intervals

Member Function Documentation

interval_type get_kernel_microseconds ( ) [inline]

The number of whole microseconds in the measurement period for kernel mode activity.

This represents the extent, in whole microseconds, of the measurement period for kernel mode activity

interval_type get_kernel_milliseconds ( ) [inline]

The number of whole milliseconds in the measurement period for kernel mode activity.

This represents the extent, in whole milliseconds, of the measurement period for kernel mode activity

interval_type get_kernel_period_count ( ) [inline]

The elapsed count in the measurement period for kernel mode activity.

This represents the extent, in machine-specific increments, of the measurement period for kernel mode activity

interval_type get_kernel_seconds ( ) [inline]

The number of whole seconds in the measurement period for kernel mode activity.

This represents the extent, in whole seconds, of the measurement period for kernel mode activity

interval_type get_microseconds ( ) [inline]

The number of whole microseconds in the measurement period.

This represents the extent, in whole microseconds, of the measurement period

interval_type get_milliseconds ( ) [inline]

The number of whole milliseconds in the measurement period.

This represents the extent, in whole milliseconds, of the measurement period

interval_type get_period_count ( ) [inline]

The elapsed count in the measurement period.

This represents the extent, in machine-specific increments, of the measurement period

interval_type get_seconds ( ) [inline]

The number of whole seconds in the measurement period.

This represents the extent, in whole seconds, of the measurement period

interval_type get_user_microseconds ( ) [inline]

The number of whole microseconds in the measurement period for user mode activity.

This represents the extent, in whole microseconds, of the measurement period for user mode activity

interval_type get_user_milliseconds ( ) [inline]

The number of whole milliseconds in the measurement period for user mode activity.

This represents the extent, in whole milliseconds, of the measurement period for user mode activity

interval_type get_user_period_count ( ) [inline]

The elapsed count in the measurement period for user mode activity.

This represents the extent, in machine-specific increments, of the measurement period for user mode activity

interval_type get_user_seconds ( ) [inline]

The number of whole seconds in the measurement period for user mode activity.

This represents the extent, in whole seconds, of the measurement period for user mode activity

void start ( ) [inline]

Starts measurement.

Begins the measurement period

void stop ( ) [inline]

Ends measurement.

Ends the measurement period

this ( ) [inline]

Constructor.

Creates an instance of the class, and caches the thread token so that measurements will be taken with respect to the thread in which the class was created.

The documentation for this class was generated from the following file:
  • perf.d


TickCounter Class Reference

List of all members.

Detailed Description

A low-cost, low-resolution performance counter.

This class provides low-resolution, but low-latency, performance monitoring and is guaranteed to be meaningful on all operating systems.

Public Types

typedef long | interval_type
The interval type.

typedef typedef PerformanceCounterScope<
TickCounter > Scope 		scope_type
The scope type.

Public Methods

void | start ()
Starts measurement.

void | stop ()
Ends measurement.

interval_type get_period_count ()
The elapsed count in the measurement period.

interval_type get_seconds ()
The number of whole seconds in the measurement period.

interval_type get_milliseconds ()
The number of whole milliseconds in the measurement period.

interval_type get_microseconds ()
The number of whole microseconds in the measurement period.

Member Typedef Documentation

typedef long interval_type

The interval type.

The type of the interval measurement, a 64-bit signed integer

typedef typedef PerformanceCounterScope<TickCounter> Scope scope_type

The scope type.

The type with which instances of the counter class can be subject to the RAII protocol in order to scope particular measurement intervals

Member Function Documentation

interval_type get_microseconds ( ) [inline]

The number of whole microseconds in the measurement period.

This represents the extent, in whole microseconds, of the measurement period

interval_type get_milliseconds ( ) [inline]

The number of whole milliseconds in the measurement period.

This represents the extent, in whole milliseconds, of the measurement period

interval_type get_period_count ( ) [inline]

The elapsed count in the measurement period.

This represents the extent, in machine-specific increments, of the measurement period

interval_type get_seconds ( ) [inline]

The number of whole seconds in the measurement period.

This represents the extent, in whole seconds, of the measurement period

void start ( ) [inline]

Starts measurement.

Begins the measurement period

void stop ( ) [inline]

Ends measurement.

Ends the measurement period

The documentation for this class was generated from the following file:
  • perf.d


Compound Member Index

SynSoft D Libraries Compound Members

Here is a list of all documented class members with links to the classes they belong to:
  • close() : Semaphore
  • counter_type : Scope
  • error() : SynchException
  • get_available_slots() : Semaphore
  • get_counter() : Scope
  • get_kernel_microseconds() : ProcessTimesCounter, ThreadTimesCounter
  • get_kernel_milliseconds() : ProcessTimesCounter, ThreadTimesCounter
  • get_kernel_period_count() : ProcessTimesCounter, ThreadTimesCounter
  • get_kernel_seconds() : ProcessTimesCounter, ThreadTimesCounter
  • get_microseconds() : PerformanceCounter, ProcessTimesCounter, ThreadTimesCounter, TickCounter, HighPerformanceCounter
  • get_milliseconds() : PerformanceCounter, ProcessTimesCounter, ThreadTimesCounter, TickCounter, HighPerformanceCounter
  • get_name() : Semaphore
  • get_num_slots() : Semaphore
  • get_period_count() : PerformanceCounter, ProcessTimesCounter, ThreadTimesCounter, TickCounter, HighPerformanceCounter
  • get_seconds() : PerformanceCounter, ProcessTimesCounter, ThreadTimesCounter, TickCounter, HighPerformanceCounter
  • get_user_microseconds() : ProcessTimesCounter, ThreadTimesCounter
  • get_user_milliseconds() : ProcessTimesCounter, ThreadTimesCounter
  • get_user_period_count() : ProcessTimesCounter, ThreadTimesCounter
  • get_user_seconds() : ProcessTimesCounter, ThreadTimesCounter
  • INFINITE : Semaphore
  • interval_type : PerformanceCounter, ProcessTimesCounter, ThreadTimesCounter, TickCounter, HighPerformanceCounter
  • release() : Semaphore
  • scope_type : PerformanceCounter, ProcessTimesCounter, ThreadTimesCounter, TickCounter, HighPerformanceCounter
  • start() : PerformanceCounter, ProcessTimesCounter, ThreadTimesCounter, TickCounter, HighPerformanceCounter
  • stop() : PerformanceCounter, ProcessTimesCounter, ThreadTimesCounter, TickCounter, HighPerformanceCounter, Scope
  • this() : Semaphore, SynchException, ThreadTimesCounter, Scope
  • wait() : Semaphore
  • ~this() : Semaphore, Scope


Alphabetical index

SynSoft D Libraries Compound Index

H
ProcessTimesCounter (synsoft::win32::perf) SynchException (synsoft::win32::synch)
HighPerformanceCounter (synsoft::win32::perf)
S
T
P
Scope (synsoft::win32::perf) ThreadTimesCounter (synsoft::win32::perf)
PerformanceCounter (synsoft::win32::perf) Semaphore (synsoft::win32::synch) TickCounter (synsoft::win32::perf)
PerformanceCounterScope< T > (synsoft::win32::perf)


Member List

HighPerformanceCounter Member List

This is the complete list of members for HighPerformanceCounter, including all inherited members.
get_microseconds() | HighPerformanceCounter | [inline]
get_milliseconds() | HighPerformanceCounter | [inline]
get_period_count() | HighPerformanceCounter | [inline]
get_seconds() | HighPerformanceCounter | [inline]
interval_type typedef | HighPerformanceCounter |
scope_type typedef | HighPerformanceCounter |
start() | HighPerformanceCounter | [inline]
stop() | HighPerformanceCounter | [inline]


Member List

PerformanceCounter Member List

This is the complete list of members for PerformanceCounter, including all inherited members.
get_microseconds() | PerformanceCounter | [inline]
get_milliseconds() | PerformanceCounter | [inline]
get_period_count() | PerformanceCounter | [inline]
get_seconds() | PerformanceCounter | [inline]
interval_type typedef | PerformanceCounter |
scope_type typedef | PerformanceCounter |
start() | PerformanceCounter | [inline]
stop() | PerformanceCounter | [inline]


Member List

Scope Member List

This is the complete list of members for Scope, including all inherited members.
counter_type typedef | Scope |
get_counter() | Scope | [inline]
stop() | Scope | [inline]
this(counter_type counter) | Scope | [inline]
~this() | Scope | [inline]


Member List

ProcessTimesCounter Member List

This is the complete list of members for ProcessTimesCounter, including all inherited members.
get_kernel_microseconds() | ProcessTimesCounter | [inline]
get_kernel_milliseconds() | ProcessTimesCounter | [inline]
get_kernel_period_count() | ProcessTimesCounter | [inline]
get_kernel_seconds() | ProcessTimesCounter | [inline]
get_microseconds() | ProcessTimesCounter | [inline]
get_milliseconds() | ProcessTimesCounter | [inline]
get_period_count() | ProcessTimesCounter | [inline]
get_seconds() | ProcessTimesCounter | [inline]
get_user_microseconds() | ProcessTimesCounter | [inline]
get_user_milliseconds() | ProcessTimesCounter | [inline]
get_user_period_count() | ProcessTimesCounter | [inline]
get_user_seconds() | ProcessTimesCounter | [inline]
interval_type typedef | ProcessTimesCounter |
scope_type typedef | ProcessTimesCounter |
start() | ProcessTimesCounter | [inline]
stop() | ProcessTimesCounter | [inline]


Member List

ThreadTimesCounter Member List

This is the complete list of members for ThreadTimesCounter, including all inherited members.
get_kernel_microseconds() | ThreadTimesCounter | [inline]
get_kernel_milliseconds() | ThreadTimesCounter | [inline]
get_kernel_period_count() | ThreadTimesCounter | [inline]
get_kernel_seconds() | ThreadTimesCounter | [inline]
get_microseconds() | ThreadTimesCounter | [inline]
get_milliseconds() | ThreadTimesCounter | [inline]
get_period_count() | ThreadTimesCounter | [inline]
get_seconds() | ThreadTimesCounter | [inline]
get_user_microseconds() | ThreadTimesCounter | [inline]
get_user_milliseconds() | ThreadTimesCounter | [inline]
get_user_period_count() | ThreadTimesCounter | [inline]
get_user_seconds() | ThreadTimesCounter | [inline]
interval_type typedef | ThreadTimesCounter |
scope_type typedef | ThreadTimesCounter |
start() | ThreadTimesCounter | [inline]
stop() | ThreadTimesCounter | [inline]
this() | ThreadTimesCounter | [inline]


Member List

TickCounter Member List

This is the complete list of members for TickCounter, including all inherited members.
get_microseconds() | TickCounter | [inline]
get_milliseconds() | TickCounter | [inline]
get_period_count() | TickCounter | [inline]
get_seconds() | TickCounter | [inline]
interval_type typedef | TickCounter |
scope_type typedef | TickCounter |
start() | TickCounter | [inline]
stop() | TickCounter | [inline]


Member List

Semaphore Member List

This is the complete list of members for Semaphore, including all inherited members.
close() | Semaphore | [inline]
get_available_slots() | Semaphore | [inline]
get_name() | Semaphore | [inline]
get_num_slots() | Semaphore | [inline]
INFINITE | Semaphore |
release(uint cSlots) | Semaphore | [inline]
release() | Semaphore | [inline]
this(int maxSlots) | Semaphore | [inline]
this(int maxSlots, int availableSlots) | Semaphore | [inline]
this(char[] name, int maxSlots) | Semaphore | [inline]
this(char[] name, int maxSlots, int availableSlots) | Semaphore | [inline]
wait(uint timeout) | Semaphore | [inline]
wait() | Semaphore | [inline]
~this() | Semaphore | [inline]


Member List

SynchException Member List

This is the complete list of members for SynchException, including all inherited members.
error() | SynchException | [inline]
this(char[] message) | SynchException | [inline]
this(char[] message, int error) | SynchException | [inline]